diff mbox series

[bug#62980,1/2] gnu: bpp-popgen: Update to 2.4.1.

Message ID 20230421000358.11316-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62980,1/2] gnu: bpp-popgen: Update to 2.4.1. | expand

Commit Message

Mădălin Ionel Patrașcu April 21, 2023, 12:03 a.m. UTC
* gnu/packages/bioinformatics.scm (bpp-popgen): Update to 2.4.1.
[source]: Remove the commit and use the release version. Changed to the github
repo.
[arguments]: Remove the disabled parallel-build.
[home-page]: Changed to new host Université Claude-Bernard Lyon 1.
---
 gnu/packages/bioinformatics.scm | 49 +++++++++++++++------------------
 1 file changed, 22 insertions(+), 27 deletions(-)


base-commit: 2d06dfc050114dba44e791d8decc8eaa705fee01
prerequisite-patch-id: 5853dbe5778b2160c2bf5dca3f01be75fcbb678c
prerequisite-patch-id: 4af2ed7c595ec571d717d161aff1ef51a8dfc365
prerequisite-patch-id: e460dac992e961a5f13af1ed99bfad48d2f0ceb5
prerequisite-patch-id: 4241e6e34dc593a321a69e135db83293eaf011f7
prerequisite-patch-id: 78c7d0a29aee256ae2df1759863ef7e6dc34102f
prerequisite-patch-id: 4dc46155f0d7730f6996403f20442c2892e08a7c
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c4cea24632..3969e205b3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2296,35 +2296,30 @@  (define-public bpp-phyl-omics
     (license license:cecill)))
 
 (define-public bpp-popgen
-  ;; The last release was in 2014 and the recommended way to install from source
-  ;; is to clone the git repository, so we do this.
-  ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
-  (let ((commit "e472bac9b1a148803895d747cd6d0c5904f85d9f"))
-    (package
-      (name "bpp-popgen")
-      (version (string-append "2.2.0-1." (string-take commit 7)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "http://biopp.univ-montp2.fr/git/bpp-popgen")
-                      (commit commit)))
-                (file-name (string-append name "-" version "-checkout"))
-                (sha256
-                 (base32
-                  "0yn82dzn1n5629nzja68xfrhi655709rjanyryb36vzkmymy6dw5"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:parallel-build? #f
-         #:tests? #f)) ; There are no tests.
-      (inputs
-       (list bpp-core bpp-seq))
-      (home-page "http://biopp.univ-montp2.fr")
-      (synopsis "Bio++ population genetics library")
-      (description
-       "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+  (package
+    (name "bpp-popgen")
+    (version "2.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/BioPP/bpp-popgen")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0bz0fhrq3dri6a0hvfc3zlvrns8mrzzlnicw5pyfa812gc1qwfvh"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ; There are no tests.
+    (inputs
+     (list bpp-core bpp-seq))
+    (home-page "https://pbil.univ-lyon1.fr/bpp-doc/bpp-popgen/html/")
+    (synopsis "Bio++ population genetics library")
+    (description
+     "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
 analysis, phylogenetics, molecular evolution and population genetics.  This
 library provides population genetics-related modules.")
-      (license license:cecill-c))))
+    (license license:cecill-c)))
 
 (define-public bpp-seq
   (package