diff mbox series

[bug#62978]

Message ID 20230420230523.6648-6-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62978] | expand

Commit Message

Mădălin Ionel Patrașcu April 20, 2023, 11:05 p.m. UTC
Date: Fri, 21 Apr 2023 00:44:40 +0200
Subject: [PATCH 6/6] gnu: Add maffilter.

* gnu/packages/bioinformatics.scm (maffilter): New variable.
---
 gnu/packages/bioinformatics.scm | 35 +++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 93082d8814..c4cea24632 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6046,6 +6046,41 @@  (define-public macs
 sequencing tag position and orientation.")
     (license license:bsd-3)))
 
+(define-public maffilter
+  (package
+    (name "maffilter")
+    (version "1.3.1")
+    (source
+      (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/jydu/maffilter/archive/v"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "0xgbadjad54hjdh743qszyv4yvdpi45519h6cj6sfgybsr93385l"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;; No tests provided
+    (inputs
+     (list bpp-core
+           bpp-phyl
+           bpp-phyl-omics
+           bpp-seq
+           bpp-seq-omics
+           boost
+           zlib))
+    (home-page "https://jydu.github.io/maffilter/")
+    (synopsis "Multiple alignment format file processor")
+    (description
+     "MafFilter is a program dedicated to the analysis of genome alignments.  It
+parses and manipulates @acronym{MAF, multiple alignment format} files as well as
+more simple fasta files.  This package can be used to design a pipeline as a
+series of consecutive filters, each performing a dedicated analysis.  Many of
+the filters are available, from alignment cleaning to phylogeny reconstruction
+and population genetics analysis.  Despite various filtering options and format
+conversion tools, MafFilter can compute a wide range of statistics (phylogenetic
+trees, nucleotide diversity, inferrence of selection, etc.).")
+    (license license:gpl3)))
+
 (define-public mafft
   (package
     (name "mafft")