diff mbox series

[bug#62978]

Message ID 20230420230523.6648-5-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62978] | expand

Commit Message

Mădălin Ionel Patrașcu April 20, 2023, 11:05 p.m. UTC
Date: Fri, 21 Apr 2023 00:33:13 +0200
Subject: [PATCH 5/6] gnu: Add bpp-phyl-omics.

* gnu/packages/bioinformatics.scm (bpp-phyl-omics): New variable.
---
 gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 576af31ae6..93082d8814 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2267,6 +2267,34 @@  (define-public bpp-phyl
 library provides phylogenetics-related modules.")
     (license license:cecill-c)))
 
+(define-public bpp-phyl-omics
+  (package
+    (name "bpp-phyl-omics")
+    (version "2.4.1")
+    (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+            (url "https://github.com/BioPP/bpp-phyl-omics")
+            (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "172psb8njkjwg3cd6gdy5w0mq8f0817v635yw4bk7146aggjzl1h"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;; I need to check this
+    (inputs
+     (list bpp-core
+           bpp-phyl
+           bpp-seq
+           bpp-seq-omics))
+    (home-page "https://github.com/BioPP/bpp-phyl-omics")
+    (synopsis "Bio++ phylogenetic library genomics components")
+    (description
+     "This library contains the genomics components of the Bio++ phylogenetics
+library.  It is part of the Bio++ project.")
+    (license license:cecill)))
+
 (define-public bpp-popgen
   ;; The last release was in 2014 and the recommended way to install from source
   ;; is to clone the git repository, so we do this.