diff mbox series

[bug#62978]

Message ID 20230420230523.6648-4-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62978] | expand

Commit Message

Mădălin Ionel Patrașcu April 20, 2023, 11:05 p.m. UTC
Date: Fri, 21 Apr 2023 00:28:46 +0200
Subject: [PATCH 4/6] gnu: Add bpp-seq-omics.

* gnu/packages/bioinformatics.scm (bpp-seq-omics): New variable.
---
 gnu/packages/bioinformatics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ad61b979dd..576af31ae6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2321,6 +2321,28 @@  (define-public bpp-seq
 library provides sequence-related modules.")
     (license license:cecill-c)))
 
+(define-public bpp-seq-omics
+  (package
+    (name "bpp-seq-omics")
+    (version "2.4.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/BioPP/bpp-seq-omics")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "1sc2xdfnfp5a6qihplp49rgrqmj89898avfy9bqaq1g2fajppgjj"))))
+    (build-system cmake-build-system)
+    (inputs
+     (list bpp-core bpp-seq))
+    (home-page "https://github.com/BioPP/bpp-seq-omics")
+    (synopsis "Bio++ sequence library genomics components")
+    (description
+     "This library contains the genomics components of the Bio++ sequence library.
+It is part of the Bio++ project.")
+    (license license:cecill)))
+
 (define-public bppsuite
   ;; The last release was in 2014 and the recommended way to install from source
   ;; is to clone the git repository, so we do this.