diff mbox series

[bug#62973] gnu: Add python-gtts.

Message ID 20230420224638.8092-1-jgart@dismail.de
State New
Headers show
Series [bug#62973] gnu: Add python-gtts. | expand

Commit Message

jgart April 20, 2023, 10:46 p.m. UTC
From: Dominik Delgado Steuter <d@delgado.nrw>

* gnu/packages/python-xyz.scm (python-gtts): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---

Hi Dominik,

Thanks for the contribution!

I disabled the tests marked with the `@pytest.mark.net` which allowed
the other tests to run and added myself as co-author.

The patch LGTM now,

jgart

 gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou April 24, 2023, 11:24 p.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> From: Dominik Delgado Steuter <d@delgado.nrw>
>
> * gnu/packages/python-xyz.scm (python-gtts): New variable.
>
> Co-authored-by: jgart <jgart@dismail.de>

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb00c2bb32..05171de7ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@ 
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20870,6 +20871,29 @@  (define-public python-translate-toolkit
      several utilities, as well as an API for building localization tools.")
     (license license:gpl2+)))
 
+(define-public python-gtts
+  (package
+    (name "python-gtts")
+    (version "2.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gTTS" version))
+              (sha256
+               (base32
+                "1jsg1prpzr7gj5sn385mkv2v1i8xfc83ycm87hvsi2j0y366plps"))))
+    (build-system pyproject-build-system)
+    (arguments
+      ;; Disable tests that require internet.
+      (list #:test-flags '(list "-k" "not net")))
+    (native-inputs
+      (list python-pytest python-testfixtures python-click python-requests))
+    (home-page "https://github.com/pndurette/gTTS")
+    (synopsis "Google Translate text-to-speech interface")
+    (description
+     "Google Text-to-Speech (gTTS), a Python library and CLI tool to interface with
+the Google Translate text-to-speech API.  Write spoken mp3 data to a file, a
+file-like object (bytestring) for further audio manipulation, or stdout.")
+    (license license:expat)))
 
 (define-public python-packaging
   (package/inherit python-packaging-bootstrap