diff mbox series

[bug#62973] gnu: Add python-gtts.

Message ID 20230420180138.16291-1-d@delgado.nrw
State New
Headers show
Series [bug#62973] gnu: Add python-gtts. | expand

Commit Message

Dominik Delgado Steuter April 20, 2023, 6:01 p.m. UTC
* gnu/packages/python-xyz.scm (python-gtts): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 61d15695752997427ed9c3491470dd76b11bd00a
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6ea91a2..921eebc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -135,6 +135,7 @@ 
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -20840,6 +20841,27 @@  (define-public python-translate-toolkit
      several utilities, as well as an API for building localization tools.")
     (license license:gpl2+)))
 
+(define-public python-gtts
+  (package
+    (name "python-gtts")
+    (version "2.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gTTS" version))
+              (sha256
+               (base32
+                "1jsg1prpzr7gj5sn385mkv2v1i8xfc83ycm87hvsi2j0y366plps"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:tests? #f)) ;tests require networking
+    (native-inputs (list python-click python-requests))
+    (home-page "https://github.com/pndurette/gTTS")
+    (synopsis "Google Translate text-to-speech interface")
+    (description
+     "Google Text-to-Speech (gTTS), a Python library and CLI tool to interface with
+the Google Translate text-to-speech API.  Write spoken mp3 data to a file, a
+file-like object (bytestring) for further audio manipulation, or stdout.")
+    (license license:expat)))
 
 (define-public python-packaging
   (package/inherit python-packaging-bootstrap