diff mbox series

[bug#62967,core-updates,2/2] gnu: valgrind: Update to 3.20.0.

Message ID 20230420132333.17102-1-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#62967,core-updates,1/2] gnu: lz4: Remove valgrind from native-inputs. | expand

Commit Message

Simon Tournier April 20, 2023, 1:23 p.m. UTC
* gnu/packages/valgrind.scm (valgrind): Update to 3.20.0.
[arguments]<phases>: Remove trailing #t.
---
 gnu/packages/valgrind.scm | 21 ++++-----------------
 1 file changed, 4 insertions(+), 17 deletions(-)

Comments

Andreas Enge April 26, 2023, 8:50 a.m. UTC | #1
Well, building this on CI is trickier than it looks at first sight:
The derivations are not changed by dropping the valgrind input from lz4,
the source code of packages downloaded via subversion is not downloaded
again, so r-minimal still fails because texlive-ms is not retried, but
just memorised as failing. I will restart a few packages by hand, and
then relaunch all failing builds.

Andreas
Andreas Enge April 26, 2023, 12:31 p.m. UTC | #2
And without a button to compare with current master, it is difficult to
judge. But r-minimal has built, as well as lots of R packages; I checked
a few missing ones, for which indeed a different input (not related to
valgrind) fails. KDE packages also do not build due to a test failure in
kpimcommon, which also appears on master.

So I am going to push.

Andreas
Simon Tournier April 28, 2023, 9:41 a.m. UTC | #3
Hi Andreas,

On mer., 26 avril 2023 at 14:31, Andreas Enge <andreas@enge.fr> wrote:
> And without a button to compare with current master, it is difficult to
> judge. But r-minimal has built, as well as lots of R packages; I checked
> a few missing ones, for which indeed a different input (not related to
> valgrind) fails. KDE packages also do not build due to a test failure in
> kpimcommon, which also appears on master.
>
> So I am going to push.

Cool!  Thanks.

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 204dd4a3c5..113cf614c2 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -40,7 +40,7 @@  (define-public valgrind
     (name "valgrind")
     ;; Note: check "guix refresh -l -e '(@ (gnu packages valgrind) valgrind)'"
     ;; when updating this package to find which branch it should go to.
-    (version "3.17.0")
+    (version "3.20.0")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://sourceware.org/pub/valgrind"
@@ -49,8 +49,7 @@  (define-public valgrind
                                         "/valgrind-" version ".tar.bz2")))
               (sha256
                (base32
-                "18l5jbk301j3462gipqn9bkfx44mdmwn0pwr73r40gl1irkfqfmd"))
-              (patches (search-patches "valgrind-enable-arm.patch"))))
+                "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
     (build-system gnu-build-system)
     (outputs '("doc"                              ;16 MB
                "out"))
@@ -69,15 +68,13 @@  (define-public valgrind
                (substitute* (find-files dir "\\.supp$")
                  (("obj:/lib") "obj:*/lib")
                  (("obj:/usr/X11R6/lib") "obj:*/lib")
-                 (("obj:/usr/lib") "obj:*/lib"))
-               #t)))
+                 (("obj:/usr/lib") "obj:*/lib")))))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((orig (format #f "~a/share/doc" (assoc-ref outputs "out")))
                    (dest (format #f "~a/share" (assoc-ref outputs "doc"))))
                (mkdir-p dest)
-               (rename-file orig dest)
-               #t))))))
+               (rename-file orig dest)))))))
     (native-inputs
      (list perl))
     (home-page "https://www.valgrind.org/")
@@ -97,16 +94,6 @@  (define-public valgrind
 (define-public valgrind/interactive
   (package/inherit
    valgrind
-   (version "3.20.0")
-   (source (origin
-             (method url-fetch)
-             (uri (list (string-append "https://sourceware.org/pub/valgrind"
-                                       "/valgrind-" version ".tar.bz2")
-                        (string-append "ftp://sourceware.org/pub/valgrind"
-                                       "/valgrind-" version ".tar.bz2")))
-             (sha256
-              (base32
-               "1ipkp6yi202pml2r0qwflysmq86dkqd8iyi1y51d6y70vcqw0dl5"))))
    (inputs
     ;; GDB is needed to provide a sane default for `--db-command'.
     (list gdb `(,(canonical-package glibc) "debug")))