diff mbox series

[bug#62957] gnu: Add texstudio.

Message ID 20230419215610.2758-1-d@delgado.nrw
State New
Headers show
Series [bug#62957] gnu: Add texstudio. | expand

Commit Message

Dominik Delgado Steuter April 19, 2023, 9:56 p.m. UTC
* gnu/packages/tex.scm (texstudio): New variable.
---
 gnu/packages/tex.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: b82a18c8a33482249c634de1e91be18ac10a3c76

Comments

Nicolas Goaziou April 25, 2023, 9:52 a.m. UTC | #1
Hello,

Dominik Delgado Steuter via Guix-patches via <guix-patches@gnu.org>
writes:

> * gnu/packages/tex.scm (texstudio): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c8f7923..9c95d00 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8591,6 +8592,32 @@  (define-public texmaker
 develop documents with LaTeX, in a single application.")
     (license license:gpl2+)))
 
+(define-public texstudio
+  (package
+    (name "texstudio")
+    (version "4.5.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/texstudio-org/texstudio")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0bzdcsc0273809hx04zqd2famq05q9rpvqcbqhkjqnqp9vxbisig"))))
+    (build-system qt-build-system)
+    (arguments
+     `(#:tests? #f)) ;tests work only with debug build
+    (native-inputs (list pkg-config poppler-qt5 qtdeclarative-5 qtsvg-5
+                         qttools-5))
+    (home-page "https://www.texstudio.org/")
+    (synopsis "Feature-packed LaTeX editor")
+    (description
+     "TeXstudio is an integrated writing environment for creating LaTeX
+documents.  It makes writing LaTeX comfortable by providing features such as
+syntax-highlighting, an integrated viewer and reference checking.")
+    (license license:gpl3)))
+
 (define-public dvisvgm
   (package
     (name "dvisvgm")