diff mbox series

[bug#62418] gnu: gdb: Update to 13.1.

Message ID 20230418204319.729894-1-code@greghogan.com
State New
Headers show
Series [bug#62418] gnu: gdb: Update to 13.1. | expand

Commit Message

Greg Hogan April 18, 2023, 8:43 p.m. UTC
Fix the patch summary / subject line.

* gnu/packages/gdb.scm (gdb-12): Rename to ...
(gdb-13): ... and update to 13.1.
(avr-gdb): Inherit from GDB-13.
---
 gnu/packages/gdb.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index fd0bc80e44..6f7b3929e3 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -149,17 +149,17 @@  (define-public gdb-11
 written in C, C++, Ada, Objective-C, Pascal and more.")
     (license gpl3+)))
 
-(define-public gdb-12
+(define-public gdb-13
   (package
     (inherit gdb-11)
-    (version "12.1")
+    (version "13.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gdb/gdb-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1vczsqcbh5y0gx7qrclpna0qzx26sk7lra6y8qzxam1biyzr65qf"))))))
+                "184m5rp5gfkf5i8b707l2hf238m2vmjx70jqn4mbx9k9ip0xanhi"))))))
 
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
@@ -173,7 +173,7 @@  (define-public gdb-minimal
                   '("libxml2" "ncurses" "python-wrapper" "source-highlight")))))
 
 (define-public avr-gdb
-  (package/inherit gdb-12
+  (package/inherit gdb-13
     (name "avr-gdb")
     (arguments
      `(#:configure-flags
@@ -182,7 +182,7 @@  (define-public avr-gdb
              "--enable-languages=c,c++"
              "--with-system-readline"
              "--enable-source-highlight")
-       ,@(package-arguments gdb-12)))
+       ,@(package-arguments gdb-13)))
     (synopsis "The GNU Debugger for AVR")
     (description
      "GDB is the GNU debugger.  With it, you can monitor what a program is