diff mbox series

[bug#62921,v2] gnu: emacs-gerbil-mode: Add emacs-gerbil-mode.

Message ID 20230418170532.12903-1-juli@incana.org
State New
Headers show
Series [bug#62921,v2] gnu: emacs-gerbil-mode: Add emacs-gerbil-mode. | expand

Commit Message

Juliana Sims April 18, 2023, 5:05 p.m. UTC
Hi,

> Maybe the whole package should inherit from `gerbil' package so version,
> source, home-page and license are already set in the parent. WDYT?

I think that's a great idea! This version of the patch does that and also
sets this package version to 1.0.

Thanks,
Juli

---------BEGIN-PATCH---------

* gnu/packages/emacs-xyz.scm (emacs-gerbil-mode): Add emacs-gerbil-mode.
---
 gnu/packages/emacs-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)


base-commit: 286cdf0bc55a29d5a63f7191edde7ea4dbd8cf2a

Comments

Ludovic Courtès April 21, 2023, 3:02 p.m. UTC | #1
Hi Juliana,

Juliana Sims <juli@incana.org> skribis:

>> Maybe the whole package should inherit from `gerbil' package so version,
>> source, home-page and license are already set in the parent. WDYT?
>
> I think that's a great idea! This version of the patch does that and also
> sets this package version to 1.0.

Applied!  Thank you & thanks Nicolas for reviewing!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6618aac332..9699fa6f32 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -125,6 +125,7 @@ 
 ;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
 ;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36015,6 +36016,22 @@  (define-public emacs-fennel-mode
 Fennel code within Emacs.")
       (license license:gpl3+))))
 
+(define-public emacs-gerbil-mode
+  (package
+    (inherit gerbil)
+    (name "emacs-gerbil-mode")
+    (version "1.0")
+    (build-system emacs-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'install 'change-directory
+                          (lambda _
+                            (chdir "etc"))))))
+    (synopsis "Emacs major-mode for editing Gerbil code")
+    (description
+     "Gerbil mode provides font-lock, indentation, navigation, and REPL for
+Gerbil code within Emacs.")))
+
 (define-public emacs-org-modern
   (package
    (name "emacs-org-modern")