diff mbox series

[bug#62922] gnu: python-lazr-restfulclient: Add missing dependency

Message ID 20230418081223.351951-1-tom@ryuslash.org
State New
Headers show
Series [bug#62922] gnu: python-lazr-restfulclient: Add missing dependency | expand

Commit Message

Tom Willemse April 18, 2023, 8:12 a.m. UTC
* gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
dependency: python-six
---
Trying to rebuild my guix home config I ran into the following error:

starting phase `sanity-check'
validating 'lazr.restfulclient' /gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages
...checking requirements: ERROR: lazr.restfulclient==0.14.4 DistributionNotFound(Requirement.parse('six'), {'lazr.restfulclient'})
error: in phase 'sanity-check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
phase `sanity-check' failed after 0.2 seconds
command "python" "/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages" failed with status 1

From what I understand from the text it indicates that the requirements.txt of
the lazr restfulclient project specifies a dependency on six, but that package
hasn't been installed in the environment. Adding this dependency fixes the issue
for me.

 gnu/packages/python-web.scm | 22 ++++++++++------------
 1 file changed, 10 insertions(+), 12 deletions(-)


base-commit: 79b2221ce43b8026eae6461a9269466cae946cac

Comments

Tom Willemse May 16, 2023, 8:31 p.m. UTC | #1
Hello!

Tom Willemse <tom@ryuslash.org> writes:

> * gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
> dependency: python-six
> ---
> Trying to rebuild my guix home config I ran into the following error:
>
> starting phase `sanity-check'
> validating 'lazr.restfulclient' /gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages
> ...checking requirements: ERROR: lazr.restfulclient==0.14.4 DistributionNotFound(Requirement.parse('six'), {'lazr.restfulclient'})
> error: in phase 'sanity-check': uncaught exception:
> %exception #<&invoke-error program: "python" arguments: ("/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages") exit-status: 1 term-signal: #f stop-signal: #f>
> phase `sanity-check' failed after 0.2 seconds
> command "python" "/gnu/store/35ix1m6m8a5s21j02ajhdyqxb2xkshfb-sanity-check.py" "/gnu/store/llar0l72885zagk7km0hvjlq4hb3g2sx-python-lazr-restfulclient-0.14.4/lib/python3.9/site-packages" failed with status 1
>
> From what I understand from the text it indicates that the requirements.txt of
> the lazr restfulclient project specifies a dependency on six, but that package
> hasn't been installed in the environment. Adding this dependency fixes the issue
> for me.
>
>  gnu/packages/python-web.scm | 22 ++++++++++------------
>  1 file changed, 10 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index d84b5efdf9..051346c66a 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -127,21 +127,19 @@ (define-public python-lazr-restfulclient
>    (package
>      (name "python-lazr-restfulclient")
>      (version "0.14.4")
> -    (source
> -     (origin
> -       (method url-fetch)
> -       (uri (pypi-uri "lazr.restfulclient" version))
> -       (sha256
> -        (base32 "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "lazr.restfulclient" version))
> +              (sha256
> +               (base32
> +                "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
>      (build-system python-build-system)
>      ;; Disable the test suite to avoid the lazr.authentication requirement,
>      ;; which requires the ancient 'oauth', a Python 2 only library.
> -    (arguments (list #:tests? #f))
> -    (propagated-inputs
> -     (list python-distro
> -           python-httplib2
> -           python-oauthlib
> -           python-wadllib))
> +    (arguments
> +     (list #:tests? #f))
> +    (propagated-inputs (list python-distro python-httplib2 python-oauthlib
> +                             python-wadllib python-six))
>      (home-page "https://launchpad.net/lazr.restfulclient")
>      (synopsis "Web client Python library extending wadlib")
>      (description "This package provides a programmable client library that
>
> base-commit: 79b2221ce43b8026eae6461a9269466cae946cac
> -- 
> 2.40.0

Apologies if this is the wrong way to go about it to add some people to
the CC, but it was pointed out to me that I should have included the
area owners in the first place.

If you would be so kind as to have a look, this issue is preventing me
from upgrading my guix installation because one of the packages I
install uses Bazaar to get the source, which is actually aliased to
Breezy, which requires the package in this patch.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d84b5efdf9..051346c66a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -127,21 +127,19 @@  (define-public python-lazr-restfulclient
   (package
     (name "python-lazr-restfulclient")
     (version "0.14.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "lazr.restfulclient" version))
-       (sha256
-        (base32 "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "lazr.restfulclient" version))
+              (sha256
+               (base32
+                "11yhlqmdf2cqbdfzn8gdmzvmcivh4fflr18zf412sflvfjrdc3xz"))))
     (build-system python-build-system)
     ;; Disable the test suite to avoid the lazr.authentication requirement,
     ;; which requires the ancient 'oauth', a Python 2 only library.
-    (arguments (list #:tests? #f))
-    (propagated-inputs
-     (list python-distro
-           python-httplib2
-           python-oauthlib
-           python-wadllib))
+    (arguments
+     (list #:tests? #f))
+    (propagated-inputs (list python-distro python-httplib2 python-oauthlib
+                             python-wadllib python-six))
     (home-page "https://launchpad.net/lazr.restfulclient")
     (synopsis "Web client Python library extending wadlib")
     (description "This package provides a programmable client library that