diff mbox series

[bug#62921] gnu: emacs-gerbil-mode: Add emacs-gerbil-mode.

Message ID 20230418033754.11120-1-juli@incana.org
State New
Headers show
Series [bug#62921] gnu: emacs-gerbil-mode: Add emacs-gerbil-mode. | expand

Commit Message

Juliana Sims April 18, 2023, 3:37 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-gerbil-mode): Add emacs-gerbil-mode.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 774a6fb12c884766856c86c00adaa8f2a1d42508

Comments

Nicolas Goaziou April 18, 2023, 1:29 p.m. UTC | #1
Hello,

Juliana Sims <juli@incana.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-gerbil-mode): Add
> emacs-gerbil-mode.

Thank you. Some comments follow.

> +(define-public emacs-gerbil-mode
> +  (package
> +    (name "emacs-gerbil-mode")
> +    (version "0.17.0")

Note: according to "gerbil-mode.el", the version is actually "1.0".
However, I understand that the file is "tagged" as 0.17.0 as a part of
the whole Gerbil package.

Maybe the whole package should inherit from `gerbil' package so version,
source, home-page and license are already set in the parent. WDYT?

> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/vyzo/gerbil")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0c0nspm659ybgmqlppdv7sxzll4hwkvcp9qmcsip6d0kz0p8r9c3"))))
> +    (build-system emacs-build-system)
> +    (arguments
> +     (list #:phases
> +           #~(modify-phases %standard-phases
> +               (add-before 'install 'change-directory
> +                 (lambda _
> +                   (chdir "etc"))))))
> +    (home-page "https://github.com/vyzo/gervil")

Typo: gervil -> gerbil

> +    (synopsis "Emacs major-mode for editing Gerbil code")
> +    (description
> +     "Gerbil mode provides font-lock, indentation, navigation, and REPL for
> +Gerbil code within Emacs.")
> +    (license (list license:lgpl2.1 license:asl2.0))))

First license is lgpl2.1+. You should also mention in a comment that one
can choose either.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c1748e7f36..185dde1672 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -125,6 +125,7 @@ 
 ;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
 ;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
+;;; Copyright © 2023 Juliana Sims <juli@incana.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35994,6 +35995,33 @@  (define-public emacs-fennel-mode
 Fennel code within Emacs.")
       (license license:gpl3+))))
 
+(define-public emacs-gerbil-mode
+  (package
+    (name "emacs-gerbil-mode")
+    (version "0.17.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vyzo/gerbil")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0c0nspm659ybgmqlppdv7sxzll4hwkvcp9qmcsip6d0kz0p8r9c3"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'install 'change-directory
+                 (lambda _
+                   (chdir "etc"))))))
+    (home-page "https://github.com/vyzo/gervil")
+    (synopsis "Emacs major-mode for editing Gerbil code")
+    (description
+     "Gerbil mode provides font-lock, indentation, navigation, and REPL for
+Gerbil code within Emacs.")
+    (license (list license:lgpl2.1 license:asl2.0))))
+
 (define-public emacs-org-modern
   (package
    (name "emacs-org-modern")