diff mbox series

[bug#62906] gnu: python-pytest-trio: Disable tests.

Message ID 20230417152743.19932-1-jgart@dismail.de
State New
Headers show
Series [bug#62906] gnu: python-pytest-trio: Disable tests. | expand

Commit Message

jgart April 17, 2023, 3:27 p.m. UTC
See the following GitHub issue on the project page:
https://github.com/python-trio/pytest-trio/issues/122

* gnu/packages/python-check.scm (python-pytest-trio)[arguments]: Disable
broken tests.
---

Hi,

pytest-trio currently causes guix pull to fail because the tests are broken.

I have diabled the tests and linked the associated issue from the project page detailing more.

all best,

jgart

 gnu/packages/python-check.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

jgart April 17, 2023, 3:33 p.m. UTC | #1
Hi,

I forgot to add that there is also an issue reporting the pytest-trio failure here by bdju:

https://issues.guix.gnu.org/62871

62906 fixes the problem by disabling the tests for pytest-trio.

all best,

jgart
Katherine Cox-Buday April 17, 2023, 4:19 p.m. UTC | #2
On 4/17/23 9:33 AM, jgart via Guix-patches via wrote:
> Hi,
> 
> I forgot to add that there is also an issue reporting the pytest-trio failure here by bdju:
> 
> https://issues.guix.gnu.org/62871
> 
> 62906 fixes the problem by disabling the tests for pytest-trio.
> 
> all best,
> 
> jgart

I'm also also running into this. I can confirm that it looks like the 
issue is upstream, and an issue is open for it.

+1 for disabling the tests (I don't have merge abilities).
Maxim Cournoyer April 18, 2023, 2:12 a.m. UTC | #3
Hello,

jgart <jgart@dismail.de> writes:

> See the following GitHub issue on the project page:
> https://github.com/python-trio/pytest-trio/issues/122
>
> * gnu/packages/python-check.scm (python-pytest-trio)[arguments]: Disable
> broken tests.
> ---
>
> Hi,
>
> pytest-trio currently causes guix pull to fail because the tests are broken.
>
> I have diabled the tests and linked the associated issue from the project page detailing more.
>
> all best,

I don't understand how that was breaking 'guix pull' for you, it
shouldn't have played a role.  I suspect extra channels.

I've pushed an updated to 0.8.0, with two tests disable in commit
27a4bfbd07022ebabc352a419c7588fcfc881d88.  Closing!
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1046602800..613fa23a99 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1095,7 +1095,9 @@  (define-public python-pytest-trio
         (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
     (build-system python-build-system)
     (arguments
-     `(#:phases
+     `(;; https://github.com/python-trio/pytest-trio/issues/122
+       #:tests? #f ; Tests are currently broken.
+       #:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda* (#:key tests? inputs outputs #:allow-other-keys)