diff mbox series

[bug#62824,v3] gnu: Add libfyaml.

Message ID 20230415061331.28846-1-levenson@mmer.org
State New
Headers show
Series [bug#62824,v3] gnu: Add libfyaml. | expand

Commit Message

Alexey Abramov April 15, 2023, 6:13 a.m. UTC
* gnu/packages/serialization.scm (libfyaml): New variable.
---
 gnu/packages/serialization.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou May 3, 2023, 12:31 p.m. UTC | #1
Hello,

Alexey Abramov via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/serialization.scm (libfyaml): New variable.

Thank you. I slightly reworded the description so it would consist of
full sentences, and applied your patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 3f0a550920..677615a53d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -12,6 +12,7 @@ 
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2020 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -426,6 +427,33 @@  (define-public libcyaml
     (home-page "https://github.com/tlsa/libcyaml")
     (license license:isc)))
 
+(define-public libfyaml
+  (package
+    (name "libfyaml")
+    (version "0.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pantoniou/libfyaml")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "002g0grddfi5y42lq06zj8266rf7h27wq76sr598ad5pxllx3y3g"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list autoconf
+           automake
+           libtool
+           pkg-config))
+    (home-page "https://github.com/pantoniou/libfyaml")
+    (synopsis "YAML version 1.2 and JSON parser/writer")
+    (description "Fully feature complete YAML parser and emitter, supporting the
+latest YAML spec and passing the full YAML testsuite.  It is designed to be very
+efficient, avoiding copies of data, and has no artificial limits like the 1024
+character limit for implicit keys.")
+    (license license:expat)))
+
 (define-public yaml-cpp
   (package
     (name "yaml-cpp")