diff mbox series

[bug#62842,07/11] gnu: dune-alugrid: Update to 2.9.0.

Message ID 20230414192736.41322-7-felgru@posteo.net
State New
Headers show
Series gnu: maths: dune-*: Update to version 2.9.0 | expand

Commit Message

Felix Gruber April 14, 2023, 7:27 p.m. UTC
* gnu/packages/maths.scm (dune-alugrid): Update to 2.9.0.
---
 gnu/packages/maths.scm | 101 ++++++++++++++++++++---------------------
 1 file changed, 49 insertions(+), 52 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 020f599f70..34fb239c73 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7064,60 +7064,57 @@  (define-public dune-localfunctions
     (license license:gpl2)))
 
 (define-public dune-alugrid
-  ;; This was the last commit on the releases/2.7 branch as of 2021-12-17,
-  ;; unfortunately there was no tag for any 2.7 release.
-  (let ((commit "51bde29a2dfa7cfac4fb73d40ffd42b9c1eb1d3d"))
-    (package
-      (name "dune-alugrid")
-      (version (git-version "2.7.1" "0" commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://gitlab.dune-project.org/extensions/dune-alugrid.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0z16wg6llzxs7vjg2yilg31vwnkz8k050j6bspg3blbym0razy15"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-include
-             (lambda _
-               (substitute* "dune/alugrid/test/test-alugrid.cc"
-                 (("doc/grids/gridfactory/testgrids")
-                  "doc/dune-grid/grids/gridfactory/testgrids"))
-               #t))
-           (add-after 'build 'build-tests
-             (lambda* (#:key inputs make-flags parallel-build? #:allow-other-keys)
-               (setenv "CPLUS_INCLUDE_PATH"
-                       (string-append (assoc-ref inputs "dune-grid") "/share"))
-               (apply invoke "make" "build_tests"
-                      `(,@(if parallel-build?
-                              `("-j" ,(number->string (parallel-job-count)))
-                              '())
-                        ,@make-flags)))))))
-      (inputs
-       (list dune-common
-             dune-geometry
-             dune-grid
-             ;; Optional
-             metis
-             openblas
-             python
-             superlu
-             gmp
-             zlib))
-      (native-inputs
-       (list gfortran pkg-config))
-      (home-page "https://dune-project.org/")
-      (synopsis "Distributed and Unified Numerics Environment")
-      (description "ALUGrid is an adaptive, loadbalancing, unstructured
+  (package
+    (name "dune-alugrid")
+    (version "2.9.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.dune-project.org/extensions/dune-alugrid.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0s41jinsfpm56nx41vkmyv3y9n072ssw9hxjm7di64zcszgpjmzd"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-include
+           (lambda _
+             (substitute* "dune/alugrid/test/test-alugrid.cc"
+               (("doc/grids/gridfactory/testgrids")
+                "doc/dune-grid/grids/gridfactory/testgrids"))
+             #t))
+         (add-after 'build 'build-tests
+           (lambda* (#:key inputs make-flags parallel-build? #:allow-other-keys)
+             (setenv "CPLUS_INCLUDE_PATH"
+                     (string-append (assoc-ref inputs "dune-grid") "/share"))
+             (apply invoke "make" "build_tests"
+                    `(,@(if parallel-build?
+                            `("-j" ,(number->string (parallel-job-count)))
+                            '())
+                      ,@make-flags)))))))
+    (inputs
+     (list dune-common
+           dune-geometry
+           dune-grid
+           ;; Optional
+           metis
+           openblas
+           python
+           superlu
+           gmp
+           zlib))
+    (native-inputs
+     (list gfortran pkg-config))
+    (home-page "https://dune-project.org/")
+    (synopsis "Distributed and Unified Numerics Environment")
+    (description "ALUGrid is an adaptive, loadbalancing, unstructured
 implementation of the DUNE grid interface supporting either simplices or
 cubes.")
-      (license license:gpl2+))))
+    (license license:gpl2+)))
 
 (define-public dune-subgrid
   ;; This was the last commit on the releases/2.7 branch as of 2021-12-17.