diff mbox series

[bug#62796,core-updates,v2,2/2] gnu: ocaml-mdx: Fix tests.

Message ID 20230412170940.3333419-2-zimon.toutoune@gmail.com
State New
Headers show
Series [bug#62796,core-updates,v2,1/2] gnu: ocaml-ppxlib: Fix tests. | expand

Commit Message

Simon Tournier April 12, 2023, 5:09 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-mdx)[arguments]: Substitue obsolete 'egrep' by
'grep -E'.
---
 gnu/packages/ocaml.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Julien Lepiller April 12, 2023, 7:54 p.m. UTC | #1
Pushed to core-updates as 8557eb9ffb909d5df8aba5ca1c444f23f083d7e9 and
a957171bc41e98e29674f99cf3dd2940ff45a0d3, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f1c4e35044..b462d315e1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9230,7 +9230,12 @@  (define-public ocaml-mdx
                             "test/bin/mdx-test/misc/no-such-prelude/test.expected")
                (("`") "'")
                (("COMMAND") "[COMMAND]")
-               (("\\.\\.\\.") "…")))))))
+               (("\\.\\.\\.") "…"))))
+         (add-after 'fix-test-format 'fix-egrep
+           (lambda _
+             ;; egrep is obsolescent; using grep -E
+             (substitute* "test/bin/mdx-test/expect/padding/test-case.md"
+               (("egrep") "grep -E")))))))
     (propagated-inputs
      (list ocaml-fmt
            ocaml-astring