diff mbox series

[bug#62753] gnu: Add emacs-eradio.

Message ID 20230412151602.3912-1-d@delgado.nrw
State New
Headers show
Series [bug#62753] gnu: Add emacs-eradio. | expand

Commit Message

Dominik Delgado Steuter April 12, 2023, 3:16 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eradio): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: dd3e5e71104a2bcbad80e52e062a144ea96b8c6a

Comments

Nicolas Goaziou April 16, 2023, 1:53 p.m. UTC | #1
Hello,

Dominik Delgado Steuter via Guix-patches via <guix-patches@gnu.org>
writes:

> * gnu/packages/emacs-xyz.scm (emacs-eradio): New variable.

Thank you.

I added a normalized commit message, bumped the revision binding, and
applied your patch.

I also subsequently fixed package license as it seems to be GPL2+, not
GPL3+.

Regards,
Nicolas Goaziou April 16, 2023, 1:55 p.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> I added a normalized commit message, bumped the revision binding, and
> applied your patch.
>
> I also subsequently fixed package license as it seems to be GPL2+, not
> GPL3+.

Please forget about this part, I was writing about another patch, not
related to this one. Sorry for the noise.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6264d4d..2a1ee30 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -124,6 +124,7 @@ 
 ;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
 ;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3101,6 +3102,30 @@  (define-public emacs-marginalia-emprise
 playback status, artist name and title for Emprise using Marginalia.")
     (license license:gpl3+)))
 
+(define-public emacs-eradio
+  (let ((commit "47769986c79def84307921f0277e9bb2714756c2")
+        (revision "0"))
+    (package
+      (name "emacs-eradio")
+      (version (git-version "0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/olavfosse/eradio")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0lks2pph44qxc9l34nr55ha667974r8ckxdwmvcp6v9mnm05317s"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/olavfosse/eradio")
+      (synopsis "Simple radio player for GNU Emacs")
+      (description
+       "Eradio is a simple internet radio player for Emacs.  Start, stop or
+toggle custom-defined channels.  An external media player like mpv or VLC is
+required.")
+      (license license:gpl3+))))
+
 
 ;;;
 ;;; Miscellaneous.