diff mbox series

[bug#62786] gnu: xonsh: Add missing input.

Message ID 20230412044802.7909-1-jgart@dismail.de
State New
Headers show
Series [bug#62786] gnu: xonsh: Add missing input. | expand

Commit Message

jgart April 12, 2023, 4:48 a.m. UTC
Xonsh vim emulation mode/environment variable does not work without this.

* gnu/packages/shell.scm (xonsh)[inputs]: Add
python-prompt-toolkit.
---
 gnu/packages/shells.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

jgart April 13, 2023, 8:35 p.m. UTC | #1
Hi Christopher,

If you find the time could you review this one liner?

It adds python-prompt-toolkit to xonsh.

Without this xonsh can't emulate vi mode :(

It would be much appreciated!

all best,

jgart
Nicolas Goaziou April 26, 2023, 12:57 p.m. UTC | #2
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> Xonsh vim emulation mode/environment variable does not work without this.
>
> * gnu/packages/shell.scm (xonsh)[inputs]: Add
> python-prompt-toolkit.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 1ffe4ce5d8..b6f4860a88 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -595,6 +595,7 @@  (define-public xonsh
     (inputs
      (list python-distro
            python-ply
+           python-prompt-toolkit
            python-pygments
            python-pyperclip
            python-setproctitle))