diff mbox series

[bug#62753] gnu: Add emacs-eradio.

Message ID 20230410084937.12440-1-d@delgado.nrw
State New
Headers show
Series [bug#62753] gnu: Add emacs-eradio. | expand

Commit Message

Dominik Delgado Steuter April 10, 2023, 8:49 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-eradio): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: a4e9842a70775a54bbe1369881b739e7ea9a6432

Comments

Nicolas Goaziou April 11, 2023, 7:13 p.m. UTC | #1
Hello,

Dominik Delgado Steuter via Guix-patches via <guix-patches@gnu.org>
writes:

>     * gnu/packages/emacs-xyz.scm (emacs-eradio): New variable.

Thank you for the patch. Some comments follow.

> +(define-public emacs-eradio
> +  (package
> +    (name "emacs-eradio")
> +    (version "20210327.1000")

We don't use MELPA date-based versioning system, unless it is also used
upstream. It isn't the case here as upstream set library's version to
0.1.

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://melpa.org/packages/eradio-"
> +                           version ".el"))

I suggest to use GitHub as upstream.

> +       (sha256
> +        (base32
> +         "0i9mfy5xck0qbbgjhagd35hxd091254w0wga60wd44n04m46h05l"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/olavfosse/eradio")
> +    (synopsis "The simple radio player for GNU Emacs")

You should drop "The" in front of the synopsis. I think "./pre-inst-env
guix lint emacs-eradio" should warn about it.

> +    (description
> +     "eradio is a simple Internet radio player for Emacs. Start, stop or
> +toggle custom-defined channels. An external media player like mpv or vlc is
> +required.")

I would capitalize "Eradio", but not "internet". Also I suggest to write
"Mpv" and "VLC".

On this topic, would it make sense to provide VLC as an input, so the
Emacs library works out of the box?

You also need to separate sentences with two spaces, according to
Texinfo syntax.

> +    (license license:gpl3)))

License is actually GPL3+.

Could you send an updated patch?

Regards,
Dominik Delgado Steuter April 12, 2023, 2:41 p.m. UTC | #2
Hi,

thank you for the review.

Am 11.04.23 um 21:13 schrieb Nicolas Goaziou:

> I suggest to use GitHub as upstream.

I saw that a couple of other Emacs-packages in this file fetched from 
melpa.org, but you are right, GitHub makes more sense.

> I would capitalize "Eradio", but not "internet". Also I suggest to write
> "Mpv" and "VLC".

I am in favor of "mpv" as that is how the project stylizes itself. 
Wikipedia also uses that notation.

> On this topic, would it make sense to provide VLC as an input, so the
> Emacs library works out of the box?

In my opinion the user should be encouraged to choose the player themself.
I for example only use mpv and would not like my system to be cluttered 
with another full-blown media player I don't use.

> Could you send an updated patch?

It comes with the next mail.

I also relocated the package definition so that it's not between two 
packages related to emprise anymore.

Regards,

Dominik D.S.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 486740c..e2ad86e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -124,6 +124,7 @@ 
 ;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
 ;;; Copyright © 2020, 2021, 2022, 2023 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3078,6 +3079,27 @@  (define-public emacs-emprise
 Selectrum.")
     (license license:gpl3+)))
 
+(define-public emacs-eradio
+  (package
+    (name "emacs-eradio")
+    (version "20210327.1000")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://melpa.org/packages/eradio-"
+                           version ".el"))
+       (sha256
+        (base32
+         "0i9mfy5xck0qbbgjhagd35hxd091254w0wga60wd44n04m46h05l"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/olavfosse/eradio")
+    (synopsis "The simple radio player for GNU Emacs")
+    (description
+     "eradio is a simple Internet radio player for Emacs. Start, stop or
+toggle custom-defined channels. An external media player like mpv or vlc is
+required.")
+    (license license:gpl3)))
+
 (define-public emacs-marginalia-emprise
   (package
     (name "emacs-marginalia-emprise")