diff mbox series

[bug#62706] gnu: python-breathe: Update to 4.35.0.

Message ID 20230407011501.13855-1-antero@mailbox.org
State New
Headers show
Series [bug#62706] gnu: python-breathe: Update to 4.35.0. | expand

Commit Message

Antero Mejr April 7, 2023, 1:15 a.m. UTC
* gnu/packages/sphinx.scm (python-breathe): Update to 4.35.0.
---
 gnu/packages/sphinx.scm | 31 ++++++++++++++++++++-----------
 1 file changed, 20 insertions(+), 11 deletions(-)

Comments

Christopher Baines April 13, 2023, 4:58 p.m. UTC | #1
Antero Mejr via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/sphinx.scm (python-breathe): Update to 4.35.0.
> ---
>  gnu/packages/sphinx.scm | 31 ++++++++++++++++++++-----------
>  1 file changed, 20 insertions(+), 11 deletions(-)

Thanks for the patch, I've just noticed that the commit message could
have used some more detail on the changes, as it's not just being
updated, but oh well. I've already pushed this to master as
1e5ef8763f7887886b00debca7f06d8ac42e7419.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index addf4393b2..40633b75c6 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -804,18 +804,27 @@  (define-public python-sphinx-rtd-theme
 (define-public python-breathe
   (package
     (name "python-breathe")
-    (version "4.34.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "breathe" version))
-       (sha256
-        (base32
-         "18fvphs1cb2cns9q82195fx7lmlwfikzwa10cczavpaax2jnh1xc"))))
+    (version "4.35.0")
+    (source (origin
+              (method git-fetch) ;git repo has tests
+              (uri (git-reference
+                    (url "https://github.com/breathe-doc/breathe")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hlcrhr533yjkz9ds83xnmn8h6z3r6vfzz7qrpy14n9j4ysyz59c"))))
     (build-system python-build-system)
-    (propagated-inputs
-     (list python-docutils python-sphinx))
-    (home-page "https://github.com/michaeljones/breathe")
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (with-directory-excursion "tests"
+                                (invoke "python" "-m" "pytest" "-v"))))))))
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-docutils python-sphinx))
+    (home-page "https://www.breathe-doc.org")
     (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
     (description "This package is an extension to reStructuredText and Sphinx
 to be able to read and render the Doxygen xml output.")