diff mbox series

[bug#62649,v2,1/2] gnu: Add qpageview.

Message ID 20230406193749.763652-1-mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#62649,v2,1/2] gnu: Add qpageview. | expand

Commit Message

Nicolas Goaziou April 6, 2023, 7:37 p.m. UTC
* gnu/packages/image-viewers.scm (qpageview): New variable.
---
 gnu/packages/image-viewers.scm | 27 ++++++++++++++++++++++++++-
 1 file changed, 26 insertions(+), 1 deletion(-)


base-commit: 6311493d7a6271bfbc51f4693857f9a12fe9965d

Comments

Nicolas Goaziou April 22, 2023, 10:05 a.m. UTC | #1
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> * gnu/packages/image-viewers.scm (qpageview): New variable.

Applied the full patch-set. Closing.
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index d0b7e93a84..96a3fa6615 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -9,7 +9,7 @@ 
 ;;; Copyright © 2017 nee <nee-git@hidamari.blue>
 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2019, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019, 2022, 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019, 2020, 2022 Guy Fleury Iteriteka <gfleury@disroot.org>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
@@ -667,6 +667,31 @@  (define-public mcomix
 For PDF support, install the @emph{mupdf} package.")
     (license license:gpl2+)))
 
+(define-public qpageview
+  (package
+    (name "qpageview")
+    (version "0.6.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/frescobaldi/qpageview")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xdhiglzqxyp05blp66l52nbzbpn10hmdm2idhncz6pf7qw16lsw"))))
+    (build-system python-build-system)
+    (home-page "https://qpageview.org/")
+    (synopsis "Page based document viewer widget for Qt5/PyQt5")
+    (inputs
+     (list python-pyqt qtbase-5))
+    (description
+     "@code{qpageview} provides a page based document viewer widget for Qt5
+and PyQt5.  It has a flexible architecture potentionally supporting many
+formats.  Currently, it supports SVG documents, images, and, using the
+Poppler-Qt5 binding, PDF documents.")
+    (license license:gpl3+)))
+
 (define-public qview
   (package
     (name "qview")