diff mbox series

[bug#62688] gnu: python-websockets: Update to 11.0.1.

Message ID 20230406054705.29947-1-jgart@dismail.de
State New
Headers show
Series [bug#62688] gnu: python-websockets: Update to 11.0.1. | expand

Commit Message

jgart April 6, 2023, 5:47 a.m. UTC
* gnu/packages/python-web.scm (python-websockets): Update to 11.0.1.
[build-system]: Use pyproject-build-system.
---

Hi,

Here's a patch updating python-websockets to the latest release. Tests are passing.

all best,

jgart

 gnu/packages/python-web.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Christopher Baines June 19, 2023, 10:28 a.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-web.scm (python-websockets): Update to 11.0.1.
> [build-system]: Use pyproject-build-system.
> ---
>
> Hi,
>
> Here's a patch updating python-websockets to the latest release. Tests are passing.
>
> all best,
>
> jgart
>
>  gnu/packages/python-web.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Hi,

The status of [1] was a bit misleading, but it looks like this change
breaks at least python-sanic-bootstrap and python-uvicorn on
x86_64-linux.

1: https://qa.guix.gnu.org/issue/62688

Would you be able to take a look?

Thanks,

Chris
jgart June 20, 2023, 3:17 p.m. UTC | #2
Hi Christopher,

> > breaks at least python-sanic-bootstrap and python-uvicorn on

Hope all is well! I looked at this a bit yesterday. 

I'll need to spend a some more time on it. 

I'll give it another go this coming weekend, potentially before then.

python-sanic-bootstrap at least can be updated which also requires packaging two new dependencies. I'm hoping this might fix it. 

This is the approach that I am going with at the moment. 

I haven't looked into python-uvicorn yet. 

If you have any further suggestions feel free to reply to this, otherwise, I'll keep you posted on the status of this ticket.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 495e13acfe..d9475e9350 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6089,7 +6089,7 @@  (define-public python-warcio
 (define-public python-websockets
   (package
     (name "python-websockets")
-    (version "10.3")
+    (version "11.0.1")
     (source
      (origin
        (method git-fetch)
@@ -6099,8 +6099,8 @@  (define-public python-websockets
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1vk7g5z977mi89hamwiqawpmibwvv9ghrf3pqva1waxmyc7gyjb5"))))
-    (build-system python-build-system)
+         "1pbkm9hd0lfkd6j25vyd3dgj6bsyrpc5bd1i0ay68f7np45jjgvh"))))
+    (build-system pyproject-build-system)
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases