diff mbox series

[bug#62683] gnu: ruby-pg: Update to 1.4.6.

Message ID 20230405190141.16315-1-yovan@gorski.stream
State New
Headers show
Series [bug#62683] gnu: ruby-pg: Update to 1.4.6. | expand

Commit Message

Yovan Naumovski April 5, 2023, 7:01 p.m. UTC
* gnu/packages/ruby.scm (ruby-pg): Update to 1.4.6.
  [arguments]: remove disable-failing-tests phase, the tests pass without it.
---
 gnu/packages/ruby.scm | 16 +++-------------
 1 file changed, 3 insertions(+), 13 deletions(-)

Comments

Nicolas Goaziou April 8, 2023, 12:11 p.m. UTC | #1
Hello,

Yovan Naumovski via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/ruby.scm (ruby-pg): Update to 1.4.6.
>   [arguments]: remove disable-failing-tests phase, the tests pass
>   without it.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3bf0f0f534..203b5754ff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7798,7 +7798,7 @@  (define-public ruby-redcloth
 (define-public ruby-pg
   (package
     (name "ruby-pg")
-    (version "1.3.5")
+    (version "1.4.6")
     (home-page "https://github.com/ged/ruby-pg")
     (source
      (origin
@@ -7809,23 +7809,13 @@  (define-public ruby-pg
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0c2k2cibd5wwdhva68j5hhfpybm3wmvn2ym4ppn5mqmddwkjkvnk"))))
+         "0k7jgx7x7p6gbsbrv2l5rq27nff2nphnls1sdq525d82b068qnfm"))))
     (build-system ruby-build-system)
     (arguments
      (list
       #:test-target "spec"
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'disable-failing-tests
-            (lambda _
-              ;; These tests fail because DNS is unavailable, giving an
-              ;; unexpected fallback executable in the connection string.
-              (substitute* "spec/pg/connection_spec.rb"
-                (("it (\"accepts an URI and adds( proper)? hostaddr\")" test)
-                 (string-append "xit " test))
-                (("it \"can create a connection option string from an option\
- string and a hash\"" test)
-                 (string-append "xit " test)))))
                (add-before 'build 'compile
                  (lambda _
                    (invoke "rake" "compile")))
@@ -7847,7 +7837,7 @@  (define-public ruby-pg
      (list postgresql))
     (synopsis "Ruby interface to PostgreSQL")
     (description "Pg is the Ruby interface to the PostgreSQL RDBMS.  It works
-with PostgreSQL 9.0 and later.")
+with PostgreSQL 9.3 and later.")
     (license license:ruby)))
 
 (define-public ruby-byebug