diff mbox series

[bug#62653] gnu: emacs-eat: Patch ncurses tic executable.

Message ID 20230403194923.5569-1-jgart@dismail.de
State New
Headers show
Series [bug#62653] gnu: emacs-eat: Patch ncurses tic executable. | expand

Commit Message

jgart April 3, 2023, 7:49 p.m. UTC
* gnu/packages/emacs-xyz.scm (arguments): Patch tic executable.
---

Reading the code now I found that there's a function that makes a call
to tic from the ncurses package so I patched it.

all best,

jgart

 gnu/packages/emacs-xyz.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Nicolas Goaziou April 4, 2023, 8:18 p.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (arguments): Patch tic executable.
> ---
>
> Reading the code now I found that there's a function that makes a call
> to tic from the ncurses package so I patched it.

Good catch!

I also moved ncurses into inputs, otherwise the executable could
be GC'ed at some point.

Applied. Thank you.

Regards,
jgart April 4, 2023, 8:20 p.m. UTC | #2
> Good catch!

Thanks! And thanks for reviewing this.
 
> otherwise the executable could be GC'ed at some point.

TIL

thank you,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b4edc680ba..9db8a07331 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27981,7 +27981,14 @@  (define-public emacs-eat
               (invoke "make" "info")))
           (add-before 'install 'build-terminfo-database
             (lambda _
-              (invoke "make" "terminfo"))))))
+              (invoke "make" "terminfo")))
+          (add-before 'install 'patch-ncurses-tic-executable
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute*
+                "eat.el"
+                (("\"tic")
+                 (string-append "\""
+                                (search-input-file inputs "/bin/tic")))))))))
     (native-inputs
      (list ncurses texinfo))
     (home-page "https://codeberg.org/akib/emacs-eat")