diff mbox series

[bug#62641] gnu: hwloc: Update to 2.9.1.

Message ID 20230403094619.73375-1-phil.swart@gmx.fr
State New
Headers show
Series [bug#62641] gnu: hwloc: Update to 2.9.1. | expand

Commit Message

Philippe SWARTVAGHER April 3, 2023, 9:46 a.m. UTC
* gnu/packages/mpi.scm (hwloc-2): Update to 2.9.1.

Patch to skip tests requiring /sys on non-x86 systems should not be
necessary anymore, as https://github.com/open-mpi/hwloc/pull/570 has
been merged in this new version.
---
 gnu/packages/mpi.scm | 15 +++------------
 1 file changed, 3 insertions(+), 12 deletions(-)


base-commit: 1d0158ab9036cff7737cbfb1678f876ae67c4ac2

Comments

Ludovic Courtès April 7, 2023, 2:51 p.m. UTC | #1
Hello!

Philippe SWARTVAGHER <phil.swart@gmx.fr> skribis:

> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.1.
>
> Patch to skip tests requiring /sys on non-x86 systems should not be
> necessary anymore, as https://github.com/open-mpi/hwloc/pull/570 has
> been merged in this new version.

Applied, thanks! :-)

Ludo’.
Ludovic Courtès April 7, 2023, 2:52 p.m. UTC | #2
Hello!

Philippe SWARTVAGHER <phil.swart@gmx.fr> skribis:

> * gnu/packages/mpi.scm (hwloc-2): Update to 2.9.1.
>
> Patch to skip tests requiring /sys on non-x86 systems should not be
> necessary anymore, as https://github.com/open-mpi/hwloc/pull/570 has
> been merged in this new version.

Applied, thanks! :-)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index baef62616f..6faa47c669 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -141,7 +141,7 @@  (define-public hwloc-1
 (define-public hwloc-2
   (package
     (inherit hwloc-1)
-    (version "2.9.0")
+    (version "2.9.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -149,7 +149,7 @@  (define-public hwloc-2
                                   "/hwloc-" version ".tar.bz2"))
               (sha256
                (base32
-                "11v8hnl6fdsdbm3wnz5gg88f2ghixjyl7jlfmywj293ab5iyjw10"))))
+                "17jr14a5ns5rpwvy28fy7xqagbvfprsz7wrsjgh5gx7y40d97i3w"))))
 
     ;; libnuma is no longer needed.
     (inputs (modify-inputs (package-inputs hwloc-1)
@@ -168,16 +168,7 @@  (define-public hwloc-2
            (add-before 'check 'skip-tests-that-require-/sys
              (lambda _
                ;; 'test-gather-topology.sh' requires /sys as of 2.9.0; skip it.
-               (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")
-
-               ;; 'hwloc_backends' also requires /sys on non-x86 systems, for
-               ;; which hwloc lacks a topology backend not reliant on the
-               ;; operating system; skip it also on these machines.
-               (substitute* "tests/hwloc/hwloc_backends.c"
-                 ,@(if (not (target-x86?))
-                       '((("putenv\\(\\(char \\*\\) \"HWLOC_L" all)
-                          (string-append "exit (77);\n" all)))
-                       '()))))
+               (setenv "HWLOC_TEST_GATHER_TOPOLOGY" "0")))
            (add-before 'check 'skip-test-that-fails-on-qemu
              (lambda _
                ;; Skip test that fails on emulated hardware due to QEMU bug: