diff mbox series

[bug#62629] gnu: guile-pipe: Remove unused install script.

Message ID 20230402200322.20226-1-jgart@dismail.de
State New
Headers show
Series [bug#62629] gnu: guile-pipe: Remove unused install script. | expand

Commit Message

jgart April 2, 2023, 8:03 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-pipe): Remove script.
---
 gnu/packages/guile-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Josselin Poiret May 12, 2023, 6:52 p.m. UTC | #1
Hi jgart,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/guile-xyz.scm (guile-pipe): Remove script.
> ---
>  gnu/packages/guile-xyz.scm | 5 ++++-
>  1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index fd8fb25da1..691635e155 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -362,7 +362,10 @@ (define-public guile-pipe
>                 (commit commit)))
>           (file-name (git-file-name name version))
>           (sha256
> -          (base32 "038gwrhfywgs8372q478wn4623lhcmkknfj4p8yaa93bykfc0fml"))))
> +          (base32 "038gwrhfywgs8372q478wn4623lhcmkknfj4p8yaa93bykfc0fml"))
> +         (modules '((guix build utils)))
> +         ;; Remove unused install script.
> +         (snippet '(begin (delete-file "install")))))
>        (build-system guile-build-system)
>        (native-inputs
>         (list guile-3.0))
> -- 
> 2.39.2

Is this really necessary?  guile-pipe builds fine without it and this
doesn't end up in the output, right?

Best,
jgart May 12, 2023, 9:18 p.m. UTC | #2
Hi Josselin, 

I checked that it doesn't end up in the output. Yes, this is unnecessary.

I'll give a closer read to guile-build-system to remind myself of the glob patterns that it matches on for copying to the output.

Thanks for the review,

jgart
Josselin Poiret May 13, 2023, 7:39 a.m. UTC | #3
Hi jgart,

"jgart" <jgart@dismail.de> writes:

> Hi Josselin, 
>
> I checked that it doesn't end up in the output. Yes, this is unnecessary.
>
> I'll give a closer read to guile-build-system to remind myself of the glob patterns that it matches on for copying to the output.

Closing then!

Best
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index fd8fb25da1..691635e155 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -362,7 +362,10 @@  (define-public guile-pipe
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "038gwrhfywgs8372q478wn4623lhcmkknfj4p8yaa93bykfc0fml"))))
+          (base32 "038gwrhfywgs8372q478wn4623lhcmkknfj4p8yaa93bykfc0fml"))
+         (modules '((guix build utils)))
+         ;; Remove unused install script.
+         (snippet '(begin (delete-file "install")))))
       (build-system guile-build-system)
       (native-inputs
        (list guile-3.0))