diff mbox series

[bug#62627] gnu: Add cl-fast-ecs.

Message ID 20230402192358.17492-1-jgart@dismail.de
State New
Headers show
Series [bug#62627] gnu: Add cl-fast-ecs. | expand

Commit Message

jgart April 2, 2023, 7:23 p.m. UTC
* gnu/packages/lisp-xyz.scm (cl-fast-ecs, ecl-cl-fast-ecs,
sbcl-cl-fast-ecs): New variables.
---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Guillaume Le Vaillant April 4, 2023, 8:27 a.m. UTC | #1
Closing as duplicate of <https://issues.guix.gnu.org/62628>.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index ff6eebed25..546364e5a9 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -241,6 +241,35 @@  (define-public ecl-reader
      ;; TODO: Tests fail on call to coreutils echo for ecl.
      `(#:tests? #f))))
 
+(define-public sbcl-cl-fast-ecs
+  (package
+   (name "sbcl-cl-fast-ecs")
+   (version "0.1.1")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://gitlab.com/lockie/cl-fast-ecs")
+           (commit version)))
+     (sha256
+      (base32
+       "06cnhm8zpyqyjr17mji5wvj4gh2glpdw8gqy1vwrq3vgphfmg560"))
+     (file-name (git-file-name name version))))
+   (build-system asdf-build-system/sbcl)
+   (native-inputs (list sbcl-parachute))
+   (inputs (list sbcl-alexandria sbcl-trivial-garbage))
+   (synopsis "Blazingly fast Entity-Component-System microframework")
+   (description "This package provides a Common Lisp implementation of
+the Entity-Component-System pattern.")
+   (home-page "https://lockie.gitlab.io/cl-fast-ecs/")
+   (license license:expat)))
+
+(define-public cl-fast-ecs
+  (sbcl-package->cl-source-package sbcl-cl-fast-ecs))
+
+(define-public ecl-cl-fast-ecs
+  (sbcl-package->ecl-package sbcl-cl-fast-ecs))
+
 (define-public sbcl-stdutils
   (let ((commit "4a4e5a4036b815318282da5dee2a22825369137b")
         (revision "0"))