diff mbox series

[bug#62532,v2] gnu: Add dool.

Message ID 20230331162530.27770-1-yovan@gorski.stream
State New
Headers show
Series [bug#62532,v2] gnu: Add dool. | expand

Commit Message

Yovan Naumovski March 31, 2023, 4:25 p.m. UTC
* gnu/packages/admin.scm (dool): New variable.
---
 gnu/packages/admin.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Nicolas Goaziou April 3, 2023, 11:14 a.m. UTC | #1
Hello,

Yovan Naumovski via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/admin.scm (dool): New variable.

Thank you!

I fixed installation directories and added smoke tests. Applied!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f48362c203..48a16ea69d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3448,6 +3448,46 @@  (define-public dstat
     (home-page "http://dag.wiee.rs/home-made/dstat/")
     (license license:gpl2+)))
 
+(define-public dool
+  (package
+    (name "dool")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/scottchiefbaker/dool")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name "dool" version))
+       (sha256
+        (base32 "13qq52lq7z3pl2mgrhwqh8c69p9x5rkyjqjswszd6vdbzm7zk7yq"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-symlinks-and-snap-packaging
+            ;; remove symlinks that make 'ensure-no-mtimes-pre-1980 fail
+            (lambda _
+              (delete-file "examples/dstat.py")
+              (delete-file-recursively "packaging/snap")))
+          (replace 'build
+            (lambda _
+              (let ((share-man (string-append #$output "/share/man")))
+                (substitute* "install.py"
+                  (("homedir  = os.path.expanduser(.*)$")
+                   (string-append "homedir = \"" #$output "\"")))
+                (invoke "python" "install.py")
+                (install-file "docs/dool.1" (string-append share-man "/man1/")))))
+          (delete 'install)
+          (delete 'check))))
+    (synopsis "Command line system resource monitoring tool")
+    (description "Dool is a command line tool to monitor many aspects of your
+system: CPU, Memory, Network, Load Average, etc.  It also includes a robust
+plug-in architecture to allow monitoring other system metrics.")
+    (home-page "https://github.com/scottchiefbaker/dool")
+    (license license:gpl2+)))
+
 (define-public thefuck
   (package
     (name "thefuck")