diff mbox series

[bug#62568] gnu: Add python-pyoo.

Message ID 20230331100913.4046-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#62568] gnu: Add python-pyoo. | expand

Commit Message

Nicolas Graves March 31, 2023, 10:09 a.m. UTC
* gnu/packages/libreoffice.scm (python-pyoo): New variable.
---
 gnu/packages/libreoffice.scm | 42 ++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Ludovic Courtès June 18, 2023, 9:10 p.m. UTC | #1
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/libreoffice.scm (python-pyoo): New variable.

This is failing according to <https://qa.guix.gnu.org/issue/62568>.

Could you take a look?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 48689b9342..35074982e4 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -1187,3 +1187,45 @@  (define (install-python-script name)
      '((release-monitoring-url
         . "https://www.libreoffice.org/download/download-libreoffice/")))
     (license license:mpl2.0)))
+
+(define-public python-pyoo
+  (package
+    (name "python-pyoo")
+    (version "1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyoo" version))
+              (sha256
+               (base32
+                "1bxj24nwrvqra0d18w0lckvm9iw6bvks1fid2b6xrpvfc5xb37ry"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f))
+    (inputs (list libreoffice))
+    (home-page "https://github.com/mila/pyoo")
+    (synopsis "Pythonic interface to Apache OpenOffice API (UNO)")
+    (description "PyOO allows you to control a running OpenOffice or
+LibreOffice program for reading and writing spreadsheet documents.  The
+library can be used for generating documents in various formats.
+
+The main advantage of the PyOO library is that it can use almost any
+functionality implemented in OpenOffice / LibreOffice applications.  On the
+other hand it needs a running process of a office suite application which is
+significant overhead.  It uses the UNO standard interface to a running
+OpenOffice or LibreOffice application.
+
+PyOO wraps a robust Python-UNO bridge to simple and Pythonic interface.
+
+Available features:
+@itemize
+@item Opening and creation of spreadsheet documents
+@item Saving documents to all formats available in OpenOffice
+@item Charts and diagrams
+@item Sheet access and manipulation
+@item Formulas
+@item Cell merging
+@item Number, text, date, and time values
+@item Cell and text formating
+@item Number formating
+@item Locales
+@end itemize")
+    (license license:expat)))