diff mbox series

[bug#62554,1/3] gnu: Add rrrs2txi.

Message ID 20230331033621.28190-1-antero@mailbox.org
State New
Headers show
Series [bug#62554,1/3] gnu: Add rrrs2txi. | expand

Commit Message

Antero Mejr March 31, 2023, 3:36 a.m. UTC
* gnu/packages/book-software.scm (rrrs2txi): New package.
* gnu/local.mk (book-software.scm): Add file.
---
 gnu/local.mk                   |  1 +
 gnu/packages/book-software.scm | 50 ++++++++++++++++++++++++++++++++++
 2 files changed, 51 insertions(+)
 create mode 100644 gnu/packages/book-software.scm
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index aee0b8a645..10070db09a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -147,6 +147,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/bioinformatics.scm		\
   %D%/packages/bittorrent.scm			\
   %D%/packages/bison.scm			\
+  %D%/packages/book-software.scm		\
   %D%/packages/boost.scm			\
   %D%/packages/bootloaders.scm			\
   %D%/packages/bootstrap.scm			\
diff --git a/gnu/packages/book-software.scm b/gnu/packages/book-software.scm
new file mode 100644
index 0000000000..ca4e47b89e
--- /dev/null
+++ b/gnu/packages/book-software.scm
@@ -0,0 +1,50 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Antero Mejr <antero@mailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages book-software)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages scheme)
+  #:use-module (gnu packages tex)
+  #:use-module (gnu packages texinfo)
+  #:use-module (guix build-system copy)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module ((guix licenses) #:prefix license:))
+
+(define-public rrrs2txi
+  (package
+    (name "rrrs2txi")
+    (version "2001-03-28")
+    (source (origin
+              (method url-fetch)
+              (uri "https://people.csail.mit.edu/jaffer/rrrs2txi.scm")
+              (sha256
+               (base32
+                "11bmm0c2plri0mf3jjabjpbs342h4983s8jdlsvhxr384j2nlyai"))))
+    (build-system copy-build-system)
+    (arguments
+     (list #:install-plan #~'(("rrrs2txi.scm" "lib/"))))
+    (home-page "https://people.csail.mit.edu/jaffer/Scheme.html")
+    (synopsis "Translate LaTeX sources r3rs, r4rs, and r5rs to texinfo")
+    (description
+     "This package provides @code{rrrs2txi.scm}, which
+translates the LaTeX r3rs, r4rs, and r5rs to texinfo format (r3rs.txi,
+r4rs.txi, and r5rs.txi).")
+    (license license:bsd-3)))