diff mbox series

[bug#62520] gnu: Add emacs-pippel.

Message ID 20230329124220.7210-2-Rostislav.Svoboda@gmail.com
State New
Headers show
Series [bug#62520] gnu: Add emacs-pippel. | expand

Commit Message

Rostislav Svoboda March 29, 2023, 12:42 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pippel): New variable.
---
 gnu/packages/emacs-xyz.scm | 48 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)

Comments

Rostislav Svoboda March 29, 2023, 12:46 p.m. UTC | #1
Hi, please ignore this patch. I messed up. Sorry.
Cheers Bost
Nicolas Goaziou March 31, 2023, 8:32 a.m. UTC | #2
Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> Hi, please ignore this patch. I messed up. Sorry. Cheers Bost

Closing.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index da2856abc8..1cdaccd366 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17288,6 +17288,54 @@  (define-public emacs-php-mode
 documentation search and a source and class browser.")
     (license license:gpl3+)))
 
+(define-public emacs-pippel
+  (let ((commit "cb194952ee150e77601d3233dabdb521b976ee79")
+        (revision "0"))
+    (package
+      (name "emacs-pippel")
+      (version (git-version "0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/arifer612/pippel")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "17606l24yyrjxa4rc0p2zj50lfbayqldw4phhi59yqf61289d520"))))
+      (build-system emacs-build-system)
+      (arguments
+       (list
+        #:include #~(cons "^pippel\\.py$" %default-include)
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'substitute-pippel-package-path
+              (lambda* (#:key outputs #:allow-other-keys)
+                (let* ((out (assoc-ref outputs "out"))
+                       (package-path (string-append
+                                      out
+                                      "/share/emacs/site-lisp/pippel-"
+                                      #$version)))
+                  (emacs-substitute-variables "pippel.el"
+                    ("pippel-package-path"
+                     package-path)))))
+            (add-after 'unpack 'substitute-python-path
+              (lambda* (#:key inputs #:allow-other-keys)
+                (emacs-substitute-variables "pippel.el"
+                  ("pippel-python-command"
+                   (search-input-file
+                    inputs
+                    "/bin/python"))))))))
+      (inputs (list python-wrapper))
+      (propagated-inputs (list emacs-dash emacs-s))
+      (home-page "https://github.com/arifer612/pippel")
+      (synopsis "Emacs frontend to Python package manager Pip")
+      (description
+       "Pippel is an Emacs frontend for the Python package manager Pip.  As
+Pippel also uses Tabulated List mode, it provides a similar package menu like
+@code{package-list-packages}.")
+      (license license:gpl3+))))
+
 (define-public emacs-pos-tip
   (package
     (name "emacs-pos-tip")