diff mbox series

[bug#62307,core-updates,v2,15/20] gnu: linux-pam: Switch to gexps.

Message ID 20230328142852.26635-16-ludo@gnu.org
State New
Headers show
Series Update Hurd and fix build failures | expand

Commit Message

Ludovic Courtès March 28, 2023, 2:28 p.m. UTC
* gnu/packages/linux.scm (linux-pam)[arguments]: Switch to gexps.
---
 gnu/packages/linux.scm | 41 +++++++++++++++++++++--------------------
 1 file changed, 21 insertions(+), 20 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b39b0637c5..1c770bf9ba 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1804,28 +1804,29 @@  (define-public linux-pam
            ;; ("cracklib" ,cracklib)
            ))
     (arguments
-     `(;; Most users, such as `shadow', expect the headers to be under
-       ;; `security'.
-       #:configure-flags (list (string-append "--includedir="
-                                              (assoc-ref %outputs "out")
-                                              "/include/security")
-                               ;; explicit libdir for pkgconfig files
-                               ;; drop with 1.5.3, which fixes
-                               ;; https://github.com/linux-pam/linux-pam/issues/466
-                               (string-append "--libdir="
-                                              (assoc-ref %outputs "out")
-                                              "/lib")
+     (list
+      ;; Most users, such as `shadow', expect the headers to be under
+      ;; `security'.
+      #:configure-flags #~(list (string-append "--includedir="
+                                               (assoc-ref %outputs "out")
+                                               "/include/security")
+                                ;; explicit libdir for pkgconfig files
+                                ;; drop with 1.5.3, which fixes
+                                ;; https://github.com/linux-pam/linux-pam/issues/466
+                                (string-append "--libdir="
+                                               (assoc-ref %outputs "out")
+                                               "/lib")
 
-                               ;; XXX: <rpc/rpc.h> is missing from glibc when
-                               ;; cross-compiling, so we have to disable NIS
-                               ;; support altogether.
-                               ,@(if (%current-target-system)
-                                     '("--disable-nis")
-                                     '()))
+                                ;; XXX: <rpc/rpc.h> is missing from glibc when
+                                ;; cross-compiling, so we have to disable NIS
+                                ;; support altogether.
+                                #$@(if (%current-target-system)
+                                       #~("--disable-nis")
+                                       #~()))
 
-       ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
-       ;; isn't available.
-       #:tests? #f))
+      ;; XXX: Tests won't run in chroot, presumably because /etc/pam.d
+      ;; isn't available.
+      #:tests? #f))
     (home-page "http://www.linux-pam.org/")
     (synopsis "Pluggable authentication modules for Linux")
     (description