diff mbox series

[bug#62472,1/2] gnu: conan: Remove some tests about git submodule.

Message ID 20230327081803.3832-1-rocktakey@gmail.com
State New
Headers show
Series gnu: conan: Remove some failed tests | expand

Commit Message

ROCKTAKEY March 27, 2023, 8:18 a.m. UTC
* gnu/packages/package-management.scm (conan): Remove some tests about git submodule.
Due to CVE-2022-39253, transport "file://" is not allowed by Git.
---
 gnu/packages/package-management.scm | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 562d228cf4..e5048c95d6 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1215,6 +1215,10 @@  (define system ,(or (%current-target-system)
                         ;; These tests expect the 'apt' command to be available.
                         "and not test_apt_check "
                         "and not test_apt_install_substitutes "
+                        ;; Due to CVE-2022-39253, transport "file://" is not allowed by Git.
+                        ;; https://lore.kernel.org/git/xmqq4jw1uku5.fsf@gitster.g/T/#u
+                        "and not test_submodule "
+                        "and not test_clone_submodule_git "
                         (if (not (string-prefix? "x86_64" system))
                             ;; These tests either assume the machine is
                             ;; x86_64, or require a cross-compiler to target