diff mbox series

[bug#62458,v2] gnu: Add avfs.

Message ID 20230326093902.29846-1-sarg@sarg.org.ru
State New
Headers show
Series [bug#62458,v2] gnu: Add avfs. | expand

Commit Message

Sergey Trofimov March 26, 2023, 9:39 a.m. UTC
* gnu/packages/file-systems.scm (avfs): New variable.
---
 gnu/packages/file-systems.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index bc5bb41fb3..ec0f7ba44b 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -260,6 +260,38 @@  (define-public cachefilesd-inotify
 @code{dnotify} to monitor file changes.")
     (license license:gpl2+)))
 
+(define-public avfs
+  (package
+    (name "avfs")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/avf/avfs/" version
+                                  "/avfs-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1kvjaaj2dlps98alpc8rhnzhk4vriw46f3y7b2h0jq2d21j3p7xd"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-library" "--enable-fuse")))
+    (native-inputs (list pkg-config))
+    (inputs (list xz fuse))
+    (synopsis "Virtual filesystem that allows browsing of compressed files")
+    (description
+     "FUSE-based filesystem that allows browsing of compressed files.  It provides
+@command{mountavfs} command that starts a small @command{avfsd} daemon.  When a
+specially formatted path under @file{~/.avfs} is accessed, the daemon will provide
+listings and content access on the fly.  The canonical form of virtual path is:
+[basepath]#handler[options][:parameters][/internalpath].  Example paths:
+@itemize
+@item ~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file
+@item ~/.avfs/#http:localhost|some|path
+@end itemize
+@code{emacs-dired-hacks} has @code{dired-avfs} module which enables seamless
+integration with @code{avfs}.")
+    (home-page "http://avf.sourceforge.net/")
+    (license license:gpl2+)))
+
 (define-public davfs2
   (package
     (name "davfs2")