diff mbox series

[bug#62457] gnu: mu: Update to 1.10.0.

Message ID 20230326091927.24054-1-all_but_last@163.com
State New
Headers show
Series [bug#62457] gnu: mu: Update to 1.10.0. | expand

Commit Message

Zhu Zihao March 26, 2023, 9:19 a.m. UTC
* gnu/packages/mail.scm (mu): Update to 1.10.0.
[source]: Use release tarball instead of git reference.
---
 gnu/packages/mail.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)

Comments

Christopher Baines March 27, 2023, 4:05 p.m. UTC | #1
Zhu Zihao <all_but_last@163.com> writes:

> * gnu/packages/mail.scm (mu): Update to 1.10.0.
> [source]: Use release tarball instead of git reference.
> ---
>  gnu/packages/mail.scm | 19 +++++++++----------
>  1 file changed, 9 insertions(+), 10 deletions(-)

Thanks, I've pushed this to the master branch as
8ced5fd4d671f4429ccdeb807e4d17342edfc6c0.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6ef4c6fdab..9f3dc2c97a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1168,16 +1168,15 @@  (define-public emacs-mew
 (define-public mu
   (package
     (name "mu")
-    (version "1.8.13")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/djcb/mu")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0y4f5p7pwmaj8733rjzg29038dw33057qlsbsq2wapvp24wcjymr"))))
+    (version "1.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/djcb/mu/releases/download/v"
+                           version "/mu-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0fmcxypvl77k7si5g3c0pak13hy2ilz8a6567m7p2apjr33j223z"))))
     (build-system meson-build-system)
     (native-inputs
      (list pkg-config