diff mbox series

[bug#62184] gnu: Add rust-1.68.

Message ID 20230325210701.22214-1-kraai@ftbfs.org
State New
Headers show
Series [bug#62184] gnu: Add rust-1.68. | expand

Commit Message

Matthew James Kraai March 25, 2023, 9:07 p.m. UTC
*  (rust-1.68): New variable.
---
 gnu/packages/rust.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Here's an updated third patch that packages 1.68.1 instead of 1.68.0.
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index a4d9fa1593..b0b940f517 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -668,6 +668,12 @@  (define rust-1.67
    ;; * error[E0277]: the trait bound `T: ~const Deref` is not satisfied
    rust-1.66 "1.67.1" "0vpzv6rm3w1wbni17ryvcw83k5klhghklylfdza3nnp8blz3sj26"))
 
+(define rust-1.68
+  (rust-bootstrapped-package
+   ;; Verified that it *doesn't* build with 1.66. e.g.:
+   ;; * error: cannot find a built-in macro with name `derive_const`
+   rust-1.67 "1.68.1" "00sxlakbhbfx74zanp8nkc5flziywy1qymfhwf4cbm01azgm3c6c"))
+
 ;;; Note: Only the latest versions of Rust are supported and tested.  The
 ;;; intermediate rusts are built for bootstrapping purposes and should not
 ;;; be relied upon.  This is to ease maintenance and reduce the time