diff mbox series

[bug#62436] gnu: obs-websocket: Remove variable

Message ID 20230325102213.32644-1-atai@atai.org
State New
Headers show
Series [bug#62436] gnu: obs-websocket: Remove variable | expand

Commit Message

Andy Tai March 25, 2023, 10:22 a.m. UTC
* gnu/packages/video.scm (obs-websocket): Remove variable
as it has been merged into current obs
---
 gnu/packages/video.scm | 36 ------------------------------------
 1 file changed, 36 deletions(-)


base-commit: 5174820753be045ba4fc7cc93da33f4e0b730bc3
prerequisite-patch-id: 88a340e0d72bd9cd0531b3441c54210b443c4318
prerequisite-patch-id: d4916c6e8f9390690cb3bd9cfd3d82443e8dd9f4
prerequisite-patch-id: 36d0f07a218ad948b4d3eff96baa45e361896f92
prerequisite-patch-id: 60c243d1f648739628f0c2d4425873d31997a669
prerequisite-patch-id: ff2af0c57998e328b08c5eceac6cea994eb616a3

Comments

Ludovic Courtès June 9, 2023, 9:08 p.m. UTC | #1
Andy Tai <atai@atai.org> skribis:

> * gnu/packages/video.scm (obs-websocket): Remove variable
> as it has been merged into current obs

Hi!  I changed ‘obs-websocket’ to a deprecated alias for ‘obs’.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0577ffa2de..787233c537 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3489,42 +3489,6 @@  (define-public obs
     (home-page "https://obsproject.com")
     (license license:gpl2+)))
 
-(define-public obs-websocket
-  (package
-    (name "obs-websocket")
-    (version "4.9.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/Palakis/obs-websocket")
-             (commit version)
-             (recursive? #t)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0giwhm0rbc578qng4invqqma935zzjlf05msz1gx986aqk654s7k"))))
-    (build-system cmake-build-system)
-    (arguments
-     `(#:tests? #f                      ;no tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'remove-permission-change
-           (lambda* _
-             (substitute* "CMakeLists.txt"
-               ;; Remove lines that set writeable permissions on outputs.
-               (("PERMISSIONS [^)]*") "")
-               (("set\\(CMAKE_INSTALL_DEFAULT_DIRECTORY_PERMISSIONS") "")
-               ;; Ug^WClever hack to comment out the next line, which is ‘)’.
-               (("(OWNER|GROUP|WORLD)_READ .*") "#")))))))
-    (inputs
-     (list obs qtbase-5))
-    (home-page "https://github.com/Palakis/obs-websocket")
-    (synopsis "OBS plugin for remote control via WebSockets")
-    (description "This OBS plugin allows you to establish a WebSocket channel
-from within your running OBS instance so that you can control it remotely from
-programs on your current machine or on other machines.")
-    (license license:gpl2+)))
-
 (define-public obs-wlrobs
   (package
     (name "obs-wlrobs")