diff mbox series

[bug#62380,staging,4/4] gnu: Add hdf5@1.14.

Message ID 20230322135711.181552-4-code@greghogan.com
State New
Headers show
Series Update hdf5. | expand

Commit Message

Greg Hogan March 22, 2023, 1:57 p.m. UTC
* gnu/packages/maths.scm (hdf5-1.14): New variable.
---
 gnu/packages/maths.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Maxim Cournoyer March 31, 2023, 3:27 a.m. UTC | #1
Hello,

I've installed the series to staging.  It seems it could have also been
on the limit to go to master, so in the future feel free to submit for
master.

Something we should look into is hide the (false positive, I assume?)
CVEs reported by guix lint:

--8<---------------cut here---------------start------------->8---
gnu/packages/maths.scm:1390:2: hdf5@1.8.23: probably vulnerable to CVE-2020-10809, CVE-2020-10810, CVE-2020-10811, CVE-2020-10812
gnu/packages/maths.scm:1515:2: hdf5@1.10.9: probably vulnerable to CVE-2020-10809, CVE-2020-10810, CVE-2020-10811, CVE-2020-10812
gnu/packages/maths.scm:1535:2: hdf5@1.12.2: probably vulnerable to CVE-2021-37501
--8<---------------cut here---------------end--------------->8---

This can be done by adding lint-hidden-cve properties, with explanatory comments.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 451a861e95..d6d3658445 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1551,6 +1551,26 @@  (define-public hdf5-1.12
         (base32 "1zlawdzb0gsvcxif14fwr5ap2gk4b6j02wirr2hcx8hkcbivp20s"))
        (patches (search-patches "hdf5-config-date.patch"))))))
 
+(define-public hdf5-1.14
+  (package
+    (inherit hdf5-1.8)
+    (version "1.14.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+                                 "hdf5-" (version-major+minor version)
+                                 "/hdf5-" version "/src/hdf5-"
+                                 version ".tar.bz2")
+                  (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+                                 "current"
+                                 (apply string-append
+                                        (take (string-split version #\.) 2))
+                                 "/src/hdf5-" version ".tar.bz2")))
+       (sha256
+        (base32 "181bdh8hp7v9xqwcby3lknr92lxlicc2hqscba3f5nhf8lrr9rz4"))
+       (patches (search-patches "hdf5-config-date.patch"))))))
+
 (define-public hdf5
   ;; Default version of HDF5.
   hdf5-1.10)