diff mbox series

[bug#62372] gnu: borgmatic: Update to 1.7.9.

Message ID 20230322081136.1155-1-sarg@sarg.org.ru
State New
Headers show
Series [bug#62372] gnu: borgmatic: Update to 1.7.9. | expand

Commit Message

Sergey Trofimov March 22, 2023, 8:11 a.m. UTC
* gnu/packages/backup.scm (borgmatic): Update to 1.7.9.
Set absolute store path to borg in commands.py.
---
 gnu/packages/backup.scm | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

Comments

Leo Famulari March 22, 2023, 4:52 p.m. UTC | #1
On Wed, Mar 22, 2023 at 09:11:36AM +0100, Sergey Trofimov wrote:
> * gnu/packages/backup.scm (borgmatic): Update to 1.7.9.
> Set absolute store path to borg in commands.py.

Thanks! Pushed as afb1373fce0aa169fea6595cfba7a00d63fd4e8f
diff mbox series

Patch

diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index cf47ac9c80..97a4c36696 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -1255,13 +1255,13 @@  (define-public disarchive
 (define-public borgmatic
   (package
     (name "borgmatic")
-    (version "1.5.22")
+    (version "1.7.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgmatic" version))
        (sha256
-        (base32 "0pvqlj17vp81i7saxqh5hsaxqz29ldrjd7bcssh4g1h0ikmnaf2r"))))
+        (base32 "1scfh90qgv8xhafnnpl3pa9d8m4rg9xgvf21yybvmsnm5v1k2x5z"))))
     (build-system python-build-system)
     (arguments
      (list #:phases
@@ -1270,10 +1270,15 @@  (define-public borgmatic
                  (lambda* (#:key inputs #:allow-other-keys)
                    ;; Set absolute store path to borg.
                    (substitute* "borgmatic/commands/borgmatic.py"
-                     (("location\\.get\\('local_path', 'borg'\\)")
-                      (string-append "location.get('local_path', '"
+                     (("\\.get\\('local_path', 'borg'\\)")
+                      (string-append ".get('local_path', '"
                                      (search-input-file inputs "bin/borg")
-                                     "')")))))
+                                     "')")))
+                   (substitute* "tests/unit/commands/test_borgmatic.py"
+                     (("(module.get_local_path.+ == )'borg'" all start)
+                      (string-append start "'"
+                                     (search-input-file inputs "bin/borg")
+                                     "'")))))
                (replace 'check
                  (lambda* (#:key tests? #:allow-other-keys)
                    (when tests?