diff mbox series

[bug#62360] gnu: sbcl-trivial-open-browser: Patch xdg-open.

Message ID 20230321231225.20999-1-jgart@dismail.de
State New
Headers show
Series [bug#62360] gnu: sbcl-trivial-open-browser: Patch xdg-open. | expand

Commit Message

jgart March 21, 2023, 11:12 p.m. UTC
* gnu/packages/lisp-xyz.scm (sbcl-trivial-open-browser): Patch it.
[inputs]: Add xdg-utils.
[arguments]: Patch xdg-open.
---
 gnu/packages/lisp-xyz.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comments

Guillaume Le Vaillant March 22, 2023, 1:41 p.m. UTC | #1
Patch pushed as 7f1f78c9463680d5e364815e7d6db0031e6cb566.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 15e929086e..955cf0fcfc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -80,6 +80,7 @@  (define-module (gnu packages lisp-xyz)
   #:use-module (gnu packages file)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages game-development)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -22568,6 +22569,16 @@  (define-public sbcl-trivial-open-browser
          (sha256
           (base32 "0ixay1piq420i6adx642qhw45l6ik7rvgk52lyz27dvx5f8yqsdb"))))
       (build-system asdf-build-system/sbcl)
+      (inputs (list xdg-utils))
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'fix-paths
+              (lambda* (#:key inputs #:allow-other-keys)
+                (substitute* "src/trivial-open-browser.lisp"
+                  (("xdg-open")
+                   (search-input-file inputs "/bin/xdg-open"))))))))
       (home-page "https://github.com/eudoxia0/trivial-open-browser")
       (synopsis "Open a browser window from Common Lisp")
       (description