diff mbox series

[bug#62337,v2] gnu: Add samplebrain.

Message ID 20230321144226.5333-1-antero@mailbox.org
State New
Headers show
Series [bug#62337,v2] gnu: Add samplebrain. | expand

Commit Message

Antero Mejr March 21, 2023, 2:42 p.m. UTC
* gnu/packages/music.scm (samplebrain): New variable.
---
Updated to 0.18.5 and corrected license field.

 gnu/packages/music.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Antero Mejr March 21, 2023, 3:04 p.m. UTC | #1
I accidentally made a new issue for this, this patch should have been
sent to issue 58809.
https://issues.guix.gnu.org/58809

Sorry about that.
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dbcb7e4564..7d941649d0 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -7149,6 +7149,40 @@  (define-public orca-music
       (home-page "https://100r.co/site/orca.html")
       (license license:expat))))
 
+(define-public samplebrain
+  (package
+    (name "samplebrain")
+    (version "0.18.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/then-try-this/samplebrain")
+                    (commit (string-append "v" version "_release"))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "17p6n16x89bbzlpn9r7w1lgr1ifxs45npn8gxymkdr3j16dhg4zy"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:tests? #f ;no tests
+           #:phases #~(modify-phases %standard-phases
+                        (replace 'configure
+                          (lambda _
+                            (substitute* "samplebrain.pro"
+                              (("\\/usr")
+                               #$output))
+                            (invoke "qmake"))))))
+    (inputs (list fftw liblo libsndfile portaudio))
+    (home-page "https://thentrythis.org/projects/samplebrain/")
+    (synopsis "Sample mashing synthesizer designed by Aphex Twin")
+    (description
+     "Samplebrain chops samples up into a 'brain' of
+interconnected small sections called blocks which are connected into a network
+by similarity.  It processes a target sample, chopping it up into blocks in
+the same way, and tries to match each block with one in its brain to play in
+realtime.")
+    (license license:gpl2+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar