diff mbox series

[bug#62322] gnu: Add font-chivo.

Message ID 20230321061319.11837-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#62322] gnu: Add font-chivo. | expand

Commit Message

Nicolas Graves March 21, 2023, 6:13 a.m. UTC
* gnu/packages/fonts.scm (font-chivo): New variable.
---
 gnu/packages/fonts.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Nicolas Goaziou April 2, 2023, 8:33 p.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/fonts.scm (font-chivo): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5d159208dd..0af8f9d227 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -52,6 +52,7 @@ 
 ;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
 ;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2022 Nguyễn Gia Phong <mcsinyx@disroot.org>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -115,6 +116,30 @@  (define-public font-artifika
 titling.")
     (license license:silofl1.1)))
 
+(define-public font-chivo
+  (let ((commit "dc61c468d79781eb5183426e88e844af16cdc3e5")
+        (revision "0"))
+    (package
+      (name "font-chivo")
+      (version (git-version "20221010" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Omnibus-Type/Chivo")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0gdsnflnzwy8ajrk93dxwjashxisln58qcqa6dh4smnk7k0a34qs"))))
+      (build-system font-build-system)
+      (home-page "https://fonts.google.com/specimen/Chivo")
+      (synopsis "The Chivo family of fonts")
+      (description "Google Chivo Fonts is a grotesque family of fonts, ideal for
+highlights and headlines.  In october 2022, the family is upgraded to a
+variable font ranging from Thin to Black, including matching italics.  The
+glyphset has also been extended, supporting now a wider number of languages.")
+      (license license:silofl1.1))))
+
 (define-public font-ibm-plex
   (package
     (name "font-ibm-plex")