diff mbox series

[bug#62306] gnu: Add phd2

Message ID 20230320215028.26102-1-sharlatanus@gmail.com
State New
Headers show
Series [bug#62306] gnu: Add phd2 | expand

Commit Message

Sharlatan Hellseher March 20, 2023, 9:50 p.m. UTC
* gnu/packages/astronomy.scm (phd2): New variable.
---
 gnu/packages/astronomy.scm | 71 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 71 insertions(+)

Comments

Maxim Cournoyer March 21, 2023, 7:24 p.m. UTC | #1
Hi,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/astronomy.scm (phd2): New variable.
> ---
>  gnu/packages/astronomy.scm | 71 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 71 insertions(+)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index 46839c802f..66040ad5f5 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -678,6 +678,77 @@ (define-public gnuastro
>  programs for the manipulation and analysis of astronomical data.")
>      (license license:gpl3+)))
>  
> +(define-public phd2
> +  (package
> +    (name "phd2")
> +    (version "2.6.11")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/OpenPHDGuiding/phd2")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "0n87xsv9gzrwk1ygws4vw397ffq40xybp5b3c3bd5kcmff0avaw9"))
> +       (modules '((guix build utils)))
> +       (snippet
> +        '(begin
> +           ;; NOTE: Keep eye on the thirdparty directory as the bundled names
> +           ;; change from relase to release.
> +           ;;
> +           ;; Remove bundles.
> +           (with-directory-excursion "thirdparty"
> +             (for-each delete-file-recursively
> +                       '("HID_Utilities"
> +                         "MallincamGuider-OSX-dylib-source.zip"
> +                         "VidCapture"
> +                         "cfitsio-3.47-patched.tar.gz"
> +                         "cfitsio-README-PHD2.txt"
> +                         "cfitsio-snprintf.patch"
> +                         "eigen-eigen-67e894c6cd8f.tar.bz2"
> +                         "gettext-0.14.4-bin.zip"
> +                         "gettext-0.14.4-dep.zip"
> +                         "gtest-1.7.0.zip"
> +                         "indiclient-44aaf5d3-win32.zip"
> +                         "libcurl-7.54.0-win32.zip"
> +                         "libdc1394-2.2.2.tar.gz"
> +                         "libindi-58b26c584049e1b9ecd55aa5f4a225677a417898.tar.gz"
> +                         "libusb-1.0.21.tar.bz2"
> +                         "openssag")))))))

To make maintenance easier, perhaps you could reuse the 'delete-all-but'
procedure from turbovnc or similar?  This has the benefit of listing
what is kept (more transparent), and if the things we do care for change
names, we will know.

Could you please send a v2 with this suggestion implemented?
Sharlatan Hellseher March 22, 2023, 11:04 a.m. UTC | #2
Hi Maxim,

Thank you for the review. I'll check that procedure and prepare simplified
v2 patch.

Oleg

On Tue, 21 Mar 2023, 19:24 Maxim Cournoyer, <maxim.cournoyer@gmail.com>
wrote:

> Hi,
>
> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>
> > * gnu/packages/astronomy.scm (phd2): New variable.
> > ---
> >  gnu/packages/astronomy.scm | 71 ++++++++++++++++++++++++++++++++++++++
> >  1 file changed, 71 insertions(+)
> >
> > diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> > index 46839c802f..66040ad5f5 100644
> > --- a/gnu/packages/astronomy.scm
> > +++ b/gnu/packages/astronomy.scm
> > @@ -678,6 +678,77 @@ (define-public gnuastro
> >  programs for the manipulation and analysis of astronomical data.")
> >      (license license:gpl3+)))
> >
> > +(define-public phd2
> > +  (package
> > +    (name "phd2")
> > +    (version "2.6.11")
> > +    (source
> > +     (origin
> > +       (method git-fetch)
> > +       (uri (git-reference
> > +             (url "https://github.com/OpenPHDGuiding/phd2")
> > +             (commit (string-append "v" version))))
> > +       (file-name (git-file-name name version))
> > +       (sha256
> > +        (base32 "0n87xsv9gzrwk1ygws4vw397ffq40xybp5b3c3bd5kcmff0avaw9"))
> > +       (modules '((guix build utils)))
> > +       (snippet
> > +        '(begin
> > +           ;; NOTE: Keep eye on the thirdparty directory as the bundled
> names
> > +           ;; change from relase to release.
> > +           ;;
> > +           ;; Remove bundles.
> > +           (with-directory-excursion "thirdparty"
> > +             (for-each delete-file-recursively
> > +                       '("HID_Utilities"
> > +                         "MallincamGuider-OSX-dylib-source.zip"
> > +                         "VidCapture"
> > +                         "cfitsio-3.47-patched.tar.gz"
> > +                         "cfitsio-README-PHD2.txt"
> > +                         "cfitsio-snprintf.patch"
> > +                         "eigen-eigen-67e894c6cd8f.tar.bz2"
> > +                         "gettext-0.14.4-bin.zip"
> > +                         "gettext-0.14.4-dep.zip"
> > +                         "gtest-1.7.0.zip"
> > +                         "indiclient-44aaf5d3-win32.zip"
> > +                         "libcurl-7.54.0-win32.zip"
> > +                         "libdc1394-2.2.2.tar.gz"
> > +
>  "libindi-58b26c584049e1b9ecd55aa5f4a225677a417898.tar.gz"
> > +                         "libusb-1.0.21.tar.bz2"
> > +                         "openssag")))))))
>
> To make maintenance easier, perhaps you could reuse the 'delete-all-but'
> procedure from turbovnc or similar?  This has the benefit of listing
> what is kept (more transparent), and if the things we do care for change
> names, we will know.
>
> Could you please send a v2 with this suggestion implemented?
>
> --
> Thanks,
> Maxim
>
Sharlatan Hellseher April 9, 2023, 7 p.m. UTC | #3
Hi,

Just a gentle ping on the status of this pach. Let me know if it
requirers to be modified more.

Thanks,
Oleg

-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 46839c802f..66040ad5f5 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -678,6 +678,77 @@  (define-public gnuastro
 programs for the manipulation and analysis of astronomical data.")
     (license license:gpl3+)))
 
+(define-public phd2
+  (package
+    (name "phd2")
+    (version "2.6.11")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OpenPHDGuiding/phd2")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0n87xsv9gzrwk1ygws4vw397ffq40xybp5b3c3bd5kcmff0avaw9"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; NOTE: Keep eye on the thirdparty directory as the bundled names
+           ;; change from relase to release.
+           ;;
+           ;; Remove bundles.
+           (with-directory-excursion "thirdparty"
+             (for-each delete-file-recursively
+                       '("HID_Utilities"
+                         "MallincamGuider-OSX-dylib-source.zip"
+                         "VidCapture"
+                         "cfitsio-3.47-patched.tar.gz"
+                         "cfitsio-README-PHD2.txt"
+                         "cfitsio-snprintf.patch"
+                         "eigen-eigen-67e894c6cd8f.tar.bz2"
+                         "gettext-0.14.4-bin.zip"
+                         "gettext-0.14.4-dep.zip"
+                         "gtest-1.7.0.zip"
+                         "indiclient-44aaf5d3-win32.zip"
+                         "libcurl-7.54.0-win32.zip"
+                         "libdc1394-2.2.2.tar.gz"
+                         "libindi-58b26c584049e1b9ecd55aa5f4a225677a417898.tar.gz"
+                         "libusb-1.0.21.tar.bz2"
+                         "openssag")))))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "-DOPENSOURCE_ONLY=yes"
+              "-DUSE_SYSTEM_CFITSIO=yes"
+              "-DUSE_SYSTEM_EIGEN3=yes"
+              "-DUSE_SYSTEM_GTEST=yes"
+              "-DUSE_SYSTEM_LIBINDI=yes"
+              "-DUSE_SYSTEM_LIBUSB=yes")))
+    (native-inputs
+     (list gettext-minimal
+           googletest
+           perl
+           pkg-config
+           python-wrapper))
+    (inputs
+     (list cfitsio
+           curl-minimal
+           eigen
+           gtk+
+           indi
+           libnova
+           libusb
+           wxwidgets
+           zlib))
+    (home-page "https://openphdguiding.org")
+    (synopsis "Teleskope guiding software")
+    (description
+     "PHD2 is the enhanced, second generation version of the PHD guiding
+software from Stark Labs to simplify the process of tracking a guide star.")
+    (license license:bsd-3)))
+
 (define-public sextractor
   (package
     (name "sextractor")