diff mbox series

[bug#62297,2/5] gnu: Add r-affyplm.

Message ID 20230320160005.1594550-2-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#62297,1/5] gnu: Add r-affyilm. | expand

Commit Message

Mădălin Ionel Patrașcu March 20, 2023, 4 p.m. UTC
* gnu/packages/bioconductor.scm (r-affyplm): New variable.
---
 gnu/packages/bioconductor.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 48aa426574..1e3753b2ec 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2124,6 +2124,36 @@  (define-public r-affyilm
 of the Langmuir model.")
     (license license:gpl3)))
 
+(define-public r-affyplm
+  (package
+    (name "r-affyplm")
+    (version "1.74.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "affyPLM" version))
+       (sha256
+        (base32 "0f0faxjzlg0znhjfvf1490yc54npkx659jx76cddm5hk7q0blv3v"))))
+    (properties `((upstream-name . "affyPLM")))
+    (build-system r-build-system)
+     (inputs (list zlib))
+    (propagated-inputs
+     (list r-affy
+           r-biobase
+           r-biocgenerics
+           r-gcrma
+           r-preprocesscore
+           r-zlibbioc))
+    (home-page "https://github.com/bmbolstad/affyPLM")
+    (synopsis "Methods for fitting probe-level models")
+    (description
+     "The affyPLM provides a package that extends and improves the functionality
+of the base affy package.  For speeding up the runs, it includes routines that make
+heavy use of compiled code.  The central focus is on implementation of methods for
+fitting probe-level models and tools using these models.  @acronym{PLM, Product
+Lifecycle Management} based quality assessment tools are also provided.")
+    (license license:gpl2+)))
+
 (define-public r-affyrnadegradation
   (package
     (name "r-affyrnadegradation")