diff mbox series

[bug#62292] gnu: Add kitsas

Message ID 20230320105602.8040-1-saku@laesvuori.fi
State New
Headers show
Series [bug#62292] gnu: Add kitsas | expand

Commit Message

Saku Laesvuori March 20, 2023, 10:56 a.m. UTC
* gnu/packages/finance.scm (kitsas): New variable.
---
 gnu/packages/finance.scm | 57 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)


base-commit: 3a2200e1ad2049ad7e25295e6b4e013f74dd84e2

Comments

Bruno Victal March 20, 2023, 6:09 p.m. UTC | #1
Hi Saku,

On 2023-03-20 10:56, Saku Laesvuori via Guix-patches via wrote:
>  
> +(define-public kitsas
> +  (package
> +    (name "kitsas")
> +    (version "4.0.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/artoh/kitupiikki/archive/refs/tags/v"
> +                    version ".tar.gz"))

Use git-fetch instead.
GitHub tarballs are not stable and their hash can change in the future.

> +              (sha256
> +               (base32
> +                "1a15axggskrvjb3r3yyr3kdxyzcygxjj756b6dzpwlca5g1l7x5w"))))
> +    (build-system qt-build-system)
> +    (inputs (list qtbase-5 libzip poppler-qt5 qtsvg-5))
> +    (arguments

[...]

> +     '(#:test-target "check"
> +       #:tests? #f

If the tests don't work, leave a comment stating such.
It's worth trying to get them working if possible though.

[...]

> +       #:phases (modify-phases %standard-phases
> +                  (replace 'configure
> +                    (lambda* _
> +                      (invoke "qmake" "kitsasproject.pro" "CONFIG+=release")))
> +                  (replace 'install
> +                    (lambda* (#:key outputs #:allow-other-keys)
> +                      (let ((out (assoc-ref outputs "out")))
> +                        (install-file "kitsas/kitsas"
> +                                      (string-append out "/bin/"))
> +                        (install-file "kitsas.png"
> +                                      (string-append out "/share/icons/"))
> +                        (install-file "kitsas.desktop"
> +                                      (string-append out
> +                                                     "/share/applications/"))))))))

Prefer list to ' and use G-Expressions here, i.e.

(arguments
 (list
  #:tests? #f ;; comment here...
  #:phases
  #~(modify-phases %standard-phases
     (replace 'install
       (lambda* _
         (install-file "kitsas/kitsas" (string-append #$output "/bin/"))
         ... )))))


> +    (home-page "https://kitsas.fi")
> +    (synopsis "Finnish bookkeeping software for small organisations")
> +    (description
> +     "The software is in Finnish only.
> +
> +      Finnish free software accounting program with the following goals and features:
> +
> +      @itemize @bullet
> +      @item
> +      Ease of use
> +      @item
> +      Digital management of documents
> +      @item
> +      Creating a digital archive
> +      @item
> +      Built-in invoicing
> +      @item
> +      Creating reports
> +      @end itemize")

You can collapse this into:

@itemize @bullet
@item Ease of use
@item Digital management of documents
...
@end itemize

> +    (license license:gpl3)))
> +    ; GPL3 with additional terms:
> +    ; - Modified versions of this software should be clearly mentioned as modified
> +    ; - Kitsas Oy will not support any modified version of this software
> +    ; - The name Kitsas Oy should not be used in any modified version

Move this comment into the package definition.


Cheers,
Bruno
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3f3fc078f0..9c27df04ad 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -109,6 +109,7 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
+  #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages protobuf)
@@ -1290,6 +1291,62 @@  (define-public keepkey-agent
 agent.")
     (license license:lgpl3)))
 
+(define-public kitsas
+  (package
+    (name "kitsas")
+    (version "4.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/artoh/kitupiikki/archive/refs/tags/v"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1a15axggskrvjb3r3yyr3kdxyzcygxjj756b6dzpwlca5g1l7x5w"))))
+    (build-system qt-build-system)
+    (inputs (list qtbase-5 libzip poppler-qt5 qtsvg-5))
+    (arguments
+     '(#:test-target "check"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda* _
+                      (invoke "qmake" "kitsasproject.pro" "CONFIG+=release")))
+                  (replace 'install
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out")))
+                        (install-file "kitsas/kitsas"
+                                      (string-append out "/bin/"))
+                        (install-file "kitsas.png"
+                                      (string-append out "/share/icons/"))
+                        (install-file "kitsas.desktop"
+                                      (string-append out
+                                                     "/share/applications/"))))))))
+    (home-page "https://kitsas.fi")
+    (synopsis "Finnish bookkeeping software for small organisations")
+    (description
+     "The software is in Finnish only.
+
+      Finnish free software accounting program with the following goals and features:
+
+      @itemize @bullet
+      @item
+      Ease of use
+      @item
+      Digital management of documents
+      @item
+      Creating a digital archive
+      @item
+      Built-in invoicing
+      @item
+      Creating reports
+      @end itemize")
+    (license license:gpl3)))
+    ; GPL3 with additional terms:
+    ; - Modified versions of this software should be clearly mentioned as modified
+    ; - Kitsas Oy will not support any modified version of this software
+    ; - The name Kitsas Oy should not be used in any modified version
+
 (define-public python-stdnum
   (package
     (name "python-stdnum")