diff mbox series

[bug#62186,2/2] gnu: Add r-rhandsontable.

Message ID 20230314150130.39995-2-navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#62187,1/2] gnu: Add r-premessa. | expand

Commit Message

nafkhamdc March 14, 2023, 3:01 p.m. UTC
* gnu/packages/bioinformatics.scm (r-rhandsontable): New variable.
---
 gnu/packages/bioinformatics.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ricardo Wurmus March 14, 2023, 4:48 p.m. UTC | #1
This one was tricky.

The package bundles minified JavaScript which we need to build from
source.  I tracked down all JavaScript source files, added them to the
native inputs, and added a build phase to process them all.

Commit 27c8ab4bf35a915a38dae574c6212e7dcbfd15dc shows the result.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7025ccd93d..bc5da864bf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -827,6 +827,30 @@  (define-public r-rhtslib12
 developers of other R packages who wish to make use of HTSlib.")
       (license license:lgpl2.0+))))
 
+(define-public r-rhandsontable
+  (package
+    (name "r-rhandsontable")
+    (version "0.3.8")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "rhandsontable" version))
+              (sha256
+               (base32
+                "07fj6npq65pq836vdwblkhprdaq4i4f13cwdmm9gmxrnk72xj7lh"))))
+    (properties `((upstream-name . "rhandsontable")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-htmlwidgets r-jsonlite r-magrittr))
+    (native-inputs (list esbuild r-knitr))
+    (home-page "http://jrowen.github.io/rhandsontable/")
+    (synopsis
+     "This package is a htmlwidget based on the handsontable.js library")
+    (description
+     "Handsontable is a data grid component with an Excel like appearance.
+Built in JavaScript, it integrates with any data source with peak efficiency.
+It comes with powerful features like data validation, sorting, grouping,
+data binding, formula support or column ordering.")
+    (license license:expat)))
+
 (define-public r-stringendo
   (let ((commit "83b8f2d82a09b33b9e895438bb523a021138be01")
         (revision "1"))