diff mbox series

[bug#62184,2/3] gnu: Add rust-1.67.

Message ID 20230314122120.2073-2-kraai@ftbfs.org
State New
Headers show
Series Package recent Rust versions | expand

Commit Message

Matthew James Kraai March 14, 2023, 12:21 p.m. UTC
*  (rust-1.67): New variable.
---
 gnu/packages/rust.scm | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index eb3721a0c3..a4d9fa1593 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -662,6 +662,12 @@  (define rust-1.66
    ;; * error[E0232]: this attribute must have a valid value
    rust-1.65 "1.66.1" "1fjr94gsicsxd2ypz4zm8aad1zdbiccr7qjfbmq8f8f7jhx96g2v"))
 
+(define rust-1.67
+  (rust-bootstrapped-package
+   ;; Verified that it *doesn't* build with 1.65. e.g.:
+   ;; * error[E0277]: the trait bound `T: ~const Deref` is not satisfied
+   rust-1.66 "1.67.1" "0vpzv6rm3w1wbni17ryvcw83k5klhghklylfdza3nnp8blz3sj26"))
+
 ;;; Note: Only the latest versions of Rust are supported and tested.  The
 ;;; intermediate rusts are built for bootstrapping purposes and should not
 ;;; be relied upon.  This is to ease maintenance and reduce the time