diff mbox series

[bug#62182] gnu: Add python-treelib.

Message ID 20230314100306.9604-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#62182] gnu: Add python-treelib. | expand

Commit Message

Nicolas Graves March 14, 2023, 10:03 a.m. UTC
* gnu/packages/python-xyz.scm (python-treelib): New variable.
---
 gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Nicolas Graves Feb. 18, 2024, 4:34 p.m. UTC | #1
# patch already merged.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..fd3fe0cae8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9199,6 +9199,24 @@  (define-public python-traitlets
 without using the configuration machinery.")
     (license license:bsd-3)))
 
+(define-public python-treelib
+  (package
+    (name "python-treelib")
+    (version "1.6.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "treelib" version))
+              (sha256
+               (base32
+                "1247rv9fbb8pw3xbkbz04q3vnvvva3hcw002gp1clp5psargzgqw"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-future))
+    (home-page "https://github.com/caesar0301/treelib")
+    (synopsis "Implementation of a tree structure in Python")
+    (description
+     "This package provides a Python implementation of a tree structure.")
+    (license license:asl2.0)))
+
 (define-public python-jupyter-core
   (package
     (name "python-jupyter-core")