diff mbox series

[bug#62138,v3] gnu: a2ps: Update to 4.15.1

Message ID 20230312205802.15196-1-atai@atai.org
State New
Headers show
Series [bug#62138,v3] gnu: a2ps: Update to 4.15.1 | expand

Commit Message

Andy Tai March 12, 2023, 8:58 p.m. UTC
* gnu/packages/pretty-print.scm (a2ps): update to 4.15.1
---
 gnu/packages/pretty-print.scm | 26 +++++++++++++++++---------
 1 file changed, 17 insertions(+), 9 deletions(-)


base-commit: 7001cc68b6d5785a8dd6aa202d4acbb2ea9364e5
prerequisite-patch-id: 307d8f7a14bf14c3134ac269547fa9eebd017239
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 7bc54c4a0b..3a3c7b008c 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -37,7 +37,9 @@  (define-module (gnu packages pretty-print)
   #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages file)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gperf)
@@ -52,14 +54,14 @@  (define-module (gnu packages pretty-print)
 (define-public a2ps
   (package
     (name "a2ps")
-    (version "4.14")
+    (version "4.15.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/a2ps/a2ps-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
+                "0aib0k566z3avv7nc3m98dcbi5xciv5hc7mrnp1sy198l25p15wp"))
               (modules '((guix build utils)))
               (snippet
                ;; Remove timestamp from the installed 'README' file.
@@ -67,19 +69,25 @@  (define-public a2ps
                   (substitute* "etc/README.in"
                     (("@date@")
                      "1st of some month, sometime after 1970"))
-                  #t))
-              (patches (search-patches
-                        "a2ps-CVE-2001-1593.patch"
-                        "a2ps-CVE-2014-0466.patch"
-                        "a2ps-CVE-2015-8107.patch"))))
+                  #t))))
     (build-system gnu-build-system)
     (inputs
-     (list psutils gv))
+     (list psutils file gv libgc libpaper))
     (native-inputs
-     (list gperf groff perl))
+     (list gperf groff perl pkg-config))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'skio-failed-tests
+           (lambda _
+                     (substitute* "tests/Makefile.am"
+                       (("encoding.tst") ""))
+                     (substitute* "tests/Makefile.am"
+                       (("prolog-2.tst") ""))
+                     (substitute* "tests/Makefile.in"
+                       (("encoding.tst") ""))
+                     (substitute* "tests/Makefile.in"
+                       (("prolog-2.tst") ""))))
          (add-before 'build 'patch-scripts
            (lambda _
              (substitute*