diff mbox series

[bug#62149] gnu: xmoto: Update to 0.6.2.

Message ID 20230312174334.119749-1-mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#62149] gnu: xmoto: Update to 0.6.2. | expand

Commit Message

Nicolas Goaziou March 12, 2023, 5:43 p.m. UTC
* gnu/packages/games.scm (xmoto): Update to 0.6.2.
[arguments]<#:phases>: Follow SDL2 switch.
[inputs]: Delete LUA-5.1, SDL, SDL-MIXER, SDL-NET and SDL-TTF.  Add LUA, SDL2,
SDL2-mixer, SDL2-NET and SDL2-TTF.
---
 gnu/packages/games.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 60a211ec705ac98483d76da7f2523f2b8966343a

Comments

Nicolas Goaziou March 15, 2023, 11:20 p.m. UTC | #1
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> * gnu/packages/games.scm (xmoto): Update to 0.6.2.
> [arguments]<#:phases>: Follow SDL2 switch.
> [inputs]: Delete LUA-5.1, SDL, SDL-MIXER, SDL-NET and SDL-TTF.  Add LUA, SDL2,
> SDL2-mixer, SDL2-NET and SDL2-TTF.

Applied. Closing.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a0d7d68c2f..31523777bd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10147,16 +10147,16 @@  (define-public q5go
 (define-public xmoto
   (package
     (name "xmoto")
-    (version "0.6.1")
+    (version "0.6.2")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/xmoto/xmoto")
-             (commit version)))
+             (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "00f5ha79lfa2iiaz66wl0hl5dapa1l15qdr7m7knzi0ll7j6z66n"))
+        (base32 "14z3yqpiyv4y5l37b12kf8ipgsmb9krb4b5d9adlrry0j43hd7wz"))
        (modules '((guix build utils)
                   (ice-9 ftw)
                   (srfi srfi-1)))
@@ -10190,7 +10190,7 @@  (define-public xmoto
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "CPATH"
                      (string-append
-                      (assoc-ref inputs "sdl") "/include/SDL:"
+                      (assoc-ref inputs "sdl") "/include/SDL2:"
                       (or (getenv "CPATH") "")))
              #t))
          (add-after 'install 'unbundle-fonts
@@ -10219,9 +10219,9 @@  (define-public xmoto
        ("libpng" ,libpng)
        ("libxdg-basedir" ,libxdg-basedir)
        ("libxml2" ,libxml2)
-       ("lua" ,lua-5.1)
+       ("lua" ,lua)
        ("ode" ,ode)
-       ("sdl" ,(sdl-union (list sdl sdl-mixer sdl-net sdl-ttf)))
+       ("sdl" ,(sdl-union (list sdl2 sdl2-mixer sdl2-net sdl2-ttf)))
        ("sqlite" ,sqlite)
        ("zlib" ,zlib)))
     (home-page "https://xmoto.tuxfamily.org/")